summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Mildenberger2015-08-13 23:33:26 +0200
committerPhilipp Mildenberger2015-08-13 23:33:26 +0200
commite631fc9f3df0227ebbfd08f0b8e21b9298fb48a4 (patch)
tree31844b5e0de21ef30c567abb3c8f27c741108298
downloadaur-e631fc9f3df0227ebbfd08f0b8e21b9298fb48a4.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD71
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7f114c762cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = bullet
+ pkgdesc = A 3D Collision Detection and Rigid Body Dynamics Library for games and animation
+ pkgver = 2.83.6.r2.g6c24193
+ pkgrel = 1
+ url = http://www.bulletphysics.com/Bullet/
+ arch = i686
+ arch = x86_64
+ license = custom:zlib
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = graphviz
+ makedepends = ttf-dejavu
+ makedepends = mesa
+ makedepends = glu
+ optdepends = glu: for the example browser
+ source = git+https://github.com/bulletphysics/bullet3.git
+ md5sums = SKIP
+
+pkgname = bullet-git
+ optdepends = bullet-docs: documentation
+ provides = bullet
+ conflicts = bullet
+
+pkgname = bullet-docs-git
+ pkgdesc = Documentation for bullet
+ depends =
+ provides = bullet-docs
+ conflicts = bullet-docs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..102caca7ddb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# $Id: PKGBUILD 243040 2015-08-05 00:47:34Z svenstaro $
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+pkgbase=bullet
+pkgname=('bullet-git' 'bullet-docs-git')
+pkgver=2.83.6.r2.g6c24193
+pkgrel=1
+pkgdesc="A 3D Collision Detection and Rigid Body Dynamics Library for games and animation"
+arch=('i686' 'x86_64')
+url="http://www.bulletphysics.com/Bullet/"
+license=('custom:zlib')
+makedepends=('cmake' 'doxygen' 'graphviz' 'ttf-dejavu' 'mesa' 'glu')
+optdepends=('glu: for the example browser')
+source=("git+https://github.com/bulletphysics/bullet3.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd bullet3
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd bullet3
+
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=1 \
+ -DINSTALL_LIBS=1 \
+ -DINSTALL_EXTRA_LIBS=1 \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+
+ cd ..
+ #sed -i 's/GENERATE_HTMLHELP.*//g' Doxyfile
+ doxygen
+}
+
+package_bullet-git() {
+ optdepends=('bullet-docs: documentation')
+ provides=('bullet')
+ conflicts=('bullet')
+
+ cd bullet3/build
+
+ # install it
+ make DESTDIR=${pkgdir} install
+
+ # install license
+ install -Dm644 ../LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE
+}
+
+package_bullet-docs-git() {
+ pkgdesc="Documentation for bullet"
+ provides=('bullet-docs')
+ conflicts=('bullet-docs')
+ depends=()
+
+ cd bullet3
+
+ # install docs
+ install -Dm644 docs/GPU_rigidbody_using_OpenCL.pdf ${pkgdir}/usr/share/doc/bullet/GPU_rigidbody_using_OpenCL.pdf
+ install -Dm644 docs/Bullet_User_Manual.pdf ${pkgdir}/usr/share/doc/bullet/Bullet_User_Manual.pdf
+ install -Dm644 docs/BulletQuickstart.pdf ${pkgdir}/usr/share/doc/bullet/BulletQuickstart.pdf
+ cp -r html ${pkgdir}/usr/share/doc/bullet/html
+}
+# vim: sw=2 ts=2 et: