summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheAifam52015-10-08 17:57:18 +0200
committerTheAifam52015-10-08 17:57:18 +0200
commit651bf2cd9fa93d079a9af45cf69fb4cc4040127b (patch)
tree7a4d0b243152320c34e5fa7f090d4a5bff26de16
downloadaur-651bf2cd9fa93d079a9af45cf69fb4cc4040127b.tar.gz
First commit, new life
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7268d10c2fe1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bullet-train-oh-my-zsh-theme-git
+ pkgdesc = An oh-my-zsh shell theme based on the Powerline Vim plugin
+ pkgver = a
+ pkgrel = 1
+ url = https://github.com/jeremyFreeAgent/oh-my-zsh-powerline-theme
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = zsh
+ depends = oh-my-zsh-git
+ provides = bullet-train-oh-my-zsh-theme-git
+ provides = oh-my-zsh-bullet-train-theme-git
+ conflicts = bullet-train-oh-my-zsh-theme
+ conflicts = oh-my-zsh-bullet-train-theme
+ source = git+https://github.com/caiogondim/bullet-train-oh-my-zsh-theme.git
+ sha256sums = SKIP
+
+pkgname = bullet-train-oh-my-zsh-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fc7c2d11018
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: TheAifam5 <aifam96 at gmail dot com>
+
+_pkgname=bullet-train-oh-my-zsh-theme
+pkgname=$_pkgname-git
+pkgver=a
+pkgrel=1
+pkgdesc='An oh-my-zsh shell theme based on the Powerline Vim plugin'
+arch=('any')
+url='https://github.com/jeremyFreeAgent/oh-my-zsh-powerline-theme'
+license=('MIT')
+depends=('zsh' 'oh-my-zsh-git')
+source=('git+https://github.com/caiogondim/bullet-train-oh-my-zsh-theme.git')
+sha256sums=('SKIP')
+makedepends=('git')
+provides=('bullet-train-oh-my-zsh-theme-git' 'oh-my-zsh-bullet-train-theme-git')
+conflicts=('bullet-train-oh-my-zsh-theme' 'oh-my-zsh-bullet-train-theme')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$_pkgname"
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ # License is inside of README
+ install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install empty documentation
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # Install the theme
+ install -D -m644 bullet-train.zsh-theme "${pkgdir}/usr/share/oh-my-zsh/themes/ bullet-train.zsh-theme"
+}
+
+# vim:set ts=4 sw=4 et: