summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schmidt2017-08-26 01:53:08 -0500
committerAlexander Schmidt2017-08-26 01:53:08 -0500
commit6fcf075d9e90b23b258767ee8f61a3aafe87ff1a (patch)
tree592c1b18574428c59372472e1d5fe0941385a621
parentdac699b10af27a4c3f5c9280364740558041f831 (diff)
downloadaur-bullycpp-git.tar.gz
Added udev rules, removed unnecessary dependency
The included udev rules should allow non-root users to access the device without needing root.
-rw-r--r--.SRCINFO1
-rw-r--r--98-serialcable.rules1
-rw-r--r--PKGBUILD6
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8837f7fabbb..968f67195255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,6 @@ pkgbase = bullycpp-git
makedepends = make
makedepends = gcc
depends = qt5-serialport
- depends = qt5-base
provides = BullyCPP
source = bullycpp::git+https://github.com/thirtythreeforty/bullycpp.git
md5sums = SKIP
diff --git a/98-serialcable.rules b/98-serialcable.rules
new file mode 100644
index 000000000000..7f8c42b40ea6
--- /dev/null
+++ b/98-serialcable.rules
@@ -0,0 +1 @@
+SUBSYSTEM=="tty", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", GROUP="users", MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
index 19dfcbbab578..c02c4a5fcaf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A driver for the Bully Bootloader for the PIC24 and dsPIC33 series of m
arch=('i686' 'x86_64')
url="https://github.com/thirtythreeforty/bullycpp"
license=('GPL3')
-depends=('qt5-serialport' 'qt5-base')
+depends=('qt5-serialport')
makedepends=('git' 'make' 'gcc')
provides=('BullyCPP')
source=("$_pkgname::git+https://github.com/thirtythreeforty/${_pkgname}.git")
@@ -21,7 +21,6 @@ prepare() {
pkgver() {
cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-
}
build() {
@@ -33,8 +32,9 @@ build() {
package() {
cd build
make PREFIX=/usr INSTALL_ROOT="$pkgdir" install
- install -D -m644 ../bullycpp/LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m644 ../bullycpp/LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m644 ../../98-serialcable.rules "$pkgdir"/etc/udev/rules.d/98-serialcable.rules
}
# vim: set ts=2 sw=2 et: