summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schmidt2017-03-17 21:34:03 -0500
committerAlexander Schmidt2017-03-17 21:34:03 -0500
commitdac699b10af27a4c3f5c9280364740558041f831 (patch)
tree4f6b93c223f11cec2aa9ce791ca5d1909af32725
downloadaur-dac699b10af27a4c3f5c9280364740558041f831.tar.gz
Added initial package files.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8837f7fabbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bullycpp-git
+ pkgdesc = A driver for the Bully Bootloader for the PIC24 and dsPIC33 series of microcontrollers.
+ pkgver = v1.0.r6.g52e5f0a
+ pkgrel = 1
+ url = https://github.com/thirtythreeforty/bullycpp
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ depends = qt5-serialport
+ depends = qt5-base
+ provides = BullyCPP
+ source = bullycpp::git+https://github.com/thirtythreeforty/bullycpp.git
+ md5sums = SKIP
+
+pkgname = bullycpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19dfcbbab578
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexander Schmidt <zyeryi@gmail.com>
+
+_pkgname=bullycpp
+pkgname=${_pkgname}-git
+pkgver=v1.0.r6.g52e5f0a
+pkgrel=1
+pkgdesc="A driver for the Bully Bootloader for the PIC24 and dsPIC33 series of microcontrollers."
+arch=('i686' 'x86_64')
+url="https://github.com/thirtythreeforty/bullycpp"
+license=('GPL3')
+depends=('qt5-serialport' 'qt5-base')
+makedepends=('git' 'make' 'gcc')
+provides=('BullyCPP')
+source=("$_pkgname::git+https://github.com/thirtythreeforty/${_pkgname}.git")
+md5sums=('SKIP')
+
+prepare() {
+ mkdir -p build
+}
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+
+}
+
+build() {
+ cd build
+ qmake PREFIX=/usr "../${_pkgname}/src/bullycpp.pro" CONFIG+=release
+ make
+}
+
+package() {
+ cd build
+ make PREFIX=/usr INSTALL_ROOT="$pkgdir" install
+ install -D -m644 ../bullycpp/LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+
+}
+
+# vim: set ts=2 sw=2 et: