summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyril Levis2019-02-16 22:44:19 +0100
committerCyril Levis2019-02-16 22:44:19 +0100
commit3f90e367ddfa9fb274634efb40bd285e6ea8aa69 (patch)
treeb8eca5c503871584a14337f552c95d94ea9f478a
downloadaur-3f90e367ddfa9fb274634efb40bd285e6ea8aa69.tar.gz
Initial upload: bum-git r54.004d795-2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43c44730e88e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bum-git
+ pkgdesc = Download and display album art for mpd/mopidy tracks.
+ pkgver = r54.004d795
+ pkgrel = 2
+ url = https://github.com/dylanaraps/bum
+ arch = any
+ license = Apache License, Version 2.0
+ makedepends = python-setuptools
+ makedepends = git
+ makedepends = python-mpv
+ depends = python
+ depends = python-mpv
+ depends = python-musicbrainzngs
+ depends = python-mpd2
+ provides = bum
+ conflicts = bum
+ source = bum::git+https://github.com/dylanaraps/bum.git
+ md5sums = SKIP
+
+pkgname = bum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..763f464d26e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Cyril Levis <pkgbuilds AT levis DOT name>
+
+pkgname=bum-git
+pkgver=r54.004d795
+pkgrel=2
+pkgdesc="Download and display album art for mpd/mopidy tracks."
+arch=('any')
+url="https://github.com/dylanaraps/bum"
+license=('Apache License, Version 2.0')
+groups=()
+depends=('python' 'python-mpv' 'python-musicbrainzngs' 'python-mpd2')
+makedepends=('python-setuptools' 'git' 'python-mpv')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/dylanaraps/bum.git")
+md5sums=('SKIP')
+
+pkgver() {
+ # Git, no tags available
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py clean --all
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root "${pkgdir}/"
+}