summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Witek2017-09-17 14:35:03 +0200
committerTobias Witek2017-09-17 14:35:03 +0200
commit6ffb77989efdde526bd231139e394872821cba6f (patch)
tree2fec420331a7fb6c9ec836f1441af2e940d88e48
downloadaur-6ffb77989efdde526bd231139e394872821cba6f.tar.gz
[bumblebee-status] Initial commit
Add v1.4.2 of bumblebee-status to AUR.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD37
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ace2201d206
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = bumblebee-status
+ pkgdesc = Modular, theme-able status line generator for the i3 window manager
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://github.com/tobi-wan-kenobi/bumblebee-status
+ arch = any
+ license = MIT
+ depends = python-netifaces
+ depends = python-psutil
+ depends = python-requests
+ optdepends = xorg-xbacklight: to display a displays brightness
+ optdepends = xorg-xset: enable/disable automatic screen locking
+ optdepends = libnotify: enable/disable automatic screen locking
+ optdepends = dnf: display DNF package update information
+ optdepends = xorg-setxkbmap: display/change the current keyboard layout
+ optdepends = redshift: display the redshifts current color
+ optdepends = pulseaudio: control pulseaudio sink/sources
+ optdepends = xorg-xrandr: enable/disable screen outputs
+ optdepends = pacman: display current status of pacman
+ optdepends = iputils: display a ping
+ optdepends = i3ipc: display titlebar
+ optdepends = fakeroot: dependency of the pacman module
+ source = bumblebee-status-1.4.2.tar.gz::https://github.com/tobi-wan-kenobi/bumblebee-status/archive/v1.4.2.tar.gz
+ sha512sums = 3a66fc469dd3b081337c9e213a1b2262f25f30977ee6ef65b9fa5a8b6aa341637832d1a5dbb74e30d68e2824e0d19d7a911eb3390dc6062707a552f429b483e8
+
+pkgname = bumblebee-status
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff7335eac5d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tobias Witek <tobi@tobi-wan-kenobi.at>
+# Contributor: Daniel M. Capella <polycitizen@gmail.com>
+
+pkgname=bumblebee-status
+pkgver=1.4.2
+pkgrel=1
+pkgdesc='Modular, theme-able status line generator for the i3 window manager'
+arch=('any')
+url=https://github.com/tobi-wan-kenobi/bumblebee-status
+license=('MIT')
+depends=('python-netifaces' 'python-psutil' 'python-requests')
+optdepends=('xorg-xbacklight: to display a displays brightness'
+ 'xorg-xset: enable/disable automatic screen locking'
+ 'libnotify: enable/disable automatic screen locking'
+ 'dnf: display DNF package update information'
+ 'xorg-setxkbmap: display/change the current keyboard layout'
+ 'redshift: display the redshifts current color'
+ 'pulseaudio: control pulseaudio sink/sources'
+ 'xorg-xrandr: enable/disable screen outputs'
+ 'pacman: display current status of pacman'
+ 'iputils: display a ping'
+ 'i3ipc: display titlebar'
+ 'fakeroot: dependency of the pacman module')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('3a66fc469dd3b081337c9e213a1b2262f25f30977ee6ef65b9fa5a8b6aa341637832d1a5dbb74e30d68e2824e0d19d7a911eb3390dc6062707a552f429b483e8')
+
+package() {
+ install -d "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/$pkgname/{bumblebee/modules,themes/icons}
+ ln -s /usr/share/$pkgname/$pkgname "$pkgdir"/usr/bin/$pkgname
+
+ cd $pkgname-$pkgver
+ cp -a --parents $pkgname bumblebee/{,modules/}*.py themes/{,icons/}*.json \
+ "$pkgdir"/usr/share/$pkgname
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}