summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Mohrfeldt2020-01-29 14:40:34 +0100
committerKonrad Mohrfeldt2020-01-29 14:40:34 +0100
commite2fef02817baf0aaaf0c15def664af6ff3883282 (patch)
tree24ac5595f48fb2f80c50054a338f76bf220f67fe
downloadaur-e2fef02817baf0aaaf0c15def664af6ff3883282.tar.gz
initial bump2version release
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2d4cce6163a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bump2version
+ pkgdesc = Version-bump your software with a single command!
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/c4urself/bump2version
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ conflicts = bumpversion
+ source = https://pypi.python.org/packages/source/b/bump2version/bump2version-1.0.0.tar.gz
+ sha256sums = cd4f3a231305e405ed8944d8ff35bd742d9bc740ad62f483bd0ca21ce7131984
+
+pkgname = bump2version
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4364198d2f59
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# ignore everthing as recommended by the AUR submission guidelines
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58e23969e15b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael J. Pento <mjpento@verizon.net>
+# Maintainer: Thomas Weißschuh <thomas t-8ch.de>
+
+pkgname=bump2version
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Version-bump your software with a single command!'
+conflicts=('bumpversion')
+arch=('any')
+url='https://github.com/c4urself/bump2version'
+license=('MIT')
+depends=('python' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/b/bump2version/bump2version-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/bump2version-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/bump2version-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+sha256sums=('cd4f3a231305e405ed8944d8ff35bd742d9bc740ad62f483bd0ca21ce7131984')