summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Wanders2018-08-28 18:19:07 +0200
committerTim Wanders2018-08-28 18:19:07 +0200
commita2495ebd59ac8dc5396543bc7de19bd406f85161 (patch)
treea04caadc1aa754bf239a0e1adbb62e040e4c52fb
parent8d870363f180bdbc1679ef37cf6c5b278cb76a48 (diff)
downloadaur-a2495ebd59ac8dc5396543bc7de19bd406f85161.tar.gz
Sync with upstream
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0efa0c7bb23..ea64d9efcb47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = bunny-git
url = https://gitlab.com/tim241/bunny
arch = any
license = GPLv3
- source = git+https://gitlab.com/tim241/bunny.git
+ source = git+https://gitlab.com/tim241/bunny.git#branch=develop
sha256sums = SKIP
pkgname = bunny-git
diff --git a/PKGBUILD b/PKGBUILD
index bcb2d1e543e8..3a4cb3632a07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,16 @@ license=('GPLv3')
depends=()
-source=("git+https://gitlab.com/tim241/${_pkgname}.git")
+source=("git+$url.git#branch=develop")
sha256sums=('SKIP')
+pkgver() {
+ git describe --tags | sed "s|-|.|g"
+}
+
package() {
cd "$_pkgname"
- make install prefix="/usr/" destdir="$pkgdir" -j1
+ make install prefix="/usr/" destdir="$pkgdir" version="$pkgver" -j1
}