summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRolf van Kleef2018-04-12 17:39:38 +0200
committerRolf van Kleef2018-04-12 17:39:38 +0200
commitf7f4a0693b33671fd6e2e49d1697d94e1c36375e (patch)
tree326972d6e40a82b13e2e3f0039cf8226dfdd61a2
downloadaur-f7f4a0693b33671fd6e2e49d1697d94e1c36375e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD77
-rw-r--r--bunq-desktop-bin.desktop11
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ae9d5d5bab4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bunq-desktop-bin
+ pkgdesc = A desktop implementation for the bunq API
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = https://github.com/BunqCommunity/BunqDesktop
+ arch = x86_64
+ license = MIT
+ depends = nodejs
+ provides = bunq-desktop
+ conflicts = bunq-desktop-git
+ conflicts = bunq-desktop-src
+ source = https://github.com/BunqCommunity/BunqDesktop/releases/download/0.8.4/linux-unpacked-0.8.4.tar.gz
+ source = https://github.com/BunqCommunity/BunqDesktop/raw/0.8.4/build/icons/512x512.png
+ source = bunq-desktop-bin.desktop
+ sha256sums = ab7371b3f18da3bf096a8a39e62f3db20f0c58423e536b4f2a6355c24e950eb1
+ sha256sums = 580274ac3f60cce7789cdb69afc67b9db43da09b04fd82ad563fdec4337302d1
+ sha256sums = 1d84f185830733bb38928fcaa33ffc0ba46140f7f116b4d5ad24c93a585a0ffa
+
+pkgname = bunq-desktop-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34cefa7d88c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56de91f41952
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Rolf van Kleef <aur@rolfvankleef.nl>
+# Contributor: Gregory Goijaerts <crecketgaming@gmail.com>
+# Contributor: Dennis Snijder <dennissnijder97@gmail.com>
+# Contributor: Nick Duijvelshoff <nick@duijvelshoff.com>
+# Contributor: basst85 <bastiaan85@gmail.com>
+# Contributor: Kees Kluskens
+# Contributor: TimZ99
+# Contributor: Emile Bons
+
+pkgname="bunq-desktop-bin"
+pkgver="0.8.4"
+pkgrel=1
+pkgdesc="A desktop implementation for the bunq API"
+url="https://github.com/BunqCommunity/BunqDesktop"
+provides=('bunq-desktop')
+conflicts=(
+ 'bunq-desktop-git'
+ 'bunq-desktop-src'
+)
+
+arch=(
+ 'x86_64'
+)
+
+license=(
+ 'MIT'
+)
+
+depends=(
+ 'nodejs'
+)
+
+makedepens=(
+ 'git'
+ 'yarn'
+)
+
+source=(
+ "https://github.com/BunqCommunity/BunqDesktop/releases/download/${pkgver}/linux-unpacked-${pkgver}.tar.gz"
+ "https://github.com/BunqCommunity/BunqDesktop/raw/${pkgver}/build/icons/512x512.png"
+ "$pkgname.desktop"
+)
+
+sha256sums=(
+ "ab7371b3f18da3bf096a8a39e62f3db20f0c58423e536b4f2a6355c24e950eb1"
+ "580274ac3f60cce7789cdb69afc67b9db43da09b04fd82ad563fdec4337302d1"
+ "1d84f185830733bb38928fcaa33ffc0ba46140f7f116b4d5ad24c93a585a0ffa"
+)
+
+package() {
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ mkdir $pkgdir/usr/share
+ mkdir $pkgdir/usr/share/pixmaps
+ mkdir $pkgdir/opt
+
+ cp -R\
+ dist/linux-unpacked\
+ $pkgdir/opt/$pkgname
+
+ cp\
+ 512x512.png\
+ $pkgdir/usr/share/pixmaps/bunq.png
+
+ pushd $pkgdir/usr/bin
+
+ ln -s\
+ ../../opt/$pkgname/bunqdesktop\
+ bunq-desktop-src
+
+ popd
+
+ desktop-file-install\
+ $pkgname.desktop\
+ --dir $pkgdir/usr/share/applications/
+}
+
diff --git a/bunq-desktop-bin.desktop b/bunq-desktop-bin.desktop
new file mode 100644
index 000000000000..98fc34a31d15
--- /dev/null
+++ b/bunq-desktop-bin.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Bunq Desktop
+Comment=A desktop implementation for the bunq API.
+Exec=bunq-desktop-src -- %u
+StartupWMClass=BunqDesktop
+Icon=bunq
+Terminal=false
+Type=Application
+Categories=Network;X-Banking;X-Money;Office;
+X-Desktop-File-Install-Version=0.1