summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens John2015-06-08 20:29:10 +0200
committerJens John2015-06-08 20:29:10 +0200
commit415d6acb0c31d12d6ff13a6f037ed115f8d84b72 (patch)
treef38ac5ca0ac60a7c768f0885716495fcaeb183f7
downloadaur-415d6acb0c31d12d6ff13a6f037ed115f8d84b72.tar.gz
Import package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b26d4248c9b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bunsen-themes-git
+ pkgdesc = BunsenLabs GTK/Openbox/Lightdm Themes
+ pkgver = r2.3a2993b
+ pkgrel = 1
+ url = https://github.com/BunsenLabs/bunsen-themes
+ arch = any
+ license = GPL3
+ license = CCPL:by-sa
+ makedepends = git
+ depends = gtk-engine-murrine
+ optdepends = lib32-gtk-engine-murrine: required for multilib (GTK2)
+ optdepends = gtk3: required for the GTK3 themes
+ provides = bunsen-themes
+ conflicts = bunsen-themes
+ source = bunsen-themes::git+https://github.com/BunsenLabs/bunsen-themes.git#branch=master
+ md5sums = SKIP
+
+pkgname = bunsen-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5ad1c1858c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: 2ion <dev@2ion.de>
+pkgname=bunsen-themes-git
+pkgver=r2.3a2993b
+pkgrel=1
+pkgdesc="BunsenLabs GTK/Openbox/Lightdm Themes"
+arch=('any')
+url="https://github.com/BunsenLabs/bunsen-themes"
+license=('GPL3' 'CCPL:by-sa')
+depends=('gtk-engine-murrine')
+makedepends=('git')
+optdepends=( \
+ 'lib32-gtk-engine-murrine: required for multilib (GTK2)' \
+ 'gtk3: required for the GTK3 themes')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('bunsen-themes::git+https://github.com/BunsenLabs/bunsen-themes.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ install -d "$pkgdir"/usr/share/themes
+ install -d "$pkgdir"/usr/share/doc/bunsen-themes-git
+
+ cp -r Bunsen-Blackish Bunsen-Blue-Dark Bunsen-Blue Bunsen-Dark Bunsen-lightdm Bunsen CrunchBang "$pkgdir"/usr/share/themes
+ cp LICENSE.{GPL,CC} "$pkgdir"/usr/share/doc/bunsen-themes-git
+}