summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens John2015-09-02 13:02:48 +0200
committerJens John2015-09-02 13:02:48 +0200
commit5a71c7620f605955405ca3d2a080fcca170c1714 (patch)
tree21356b08fb15508e4ef3cb7878f5dc46e3fe7711
downloadaur-5a71c7620f605955405ca3d2a080fcca170c1714.tar.gz
initial package
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
-rw-r--r--bl-exit-python2-path.patch4
-rw-r--r--bl-hotcorners-syntax.patch4
-rw-r--r--bl-kb-python2-path.patch8
5 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..feaf86569248
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = bunsen-utilities-git
+ pkgdesc = Collection of utility scripts
+ pkgver = r72.22e76e4
+ pkgrel = 1
+ url = https://github.com/BunsenLabs/bunsen-utilities
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = pygtk
+ depends = python-xlib
+ depends = python-lxml
+ optdepends = upower: Required for bl-exit
+ optdepends = zenity: Required bl-conkyzen and bl-tint2edit
+ provides = bunsen-utilities
+ conflicts = bunsen-utilities
+ source = bunsen-utilities::git+https://github.com/BunsenLabs/bunsen-utilities.git#branch=master
+ source = https://raw.githubusercontent.com/Unia/bunsen-utilities/master/bl-aerosnap
+ source = https://raw.githubusercontent.com/Unia/bunsen-utilities/rewrite-hotcorners/bl-hotcorners
+ source = bl-kb-python2-path.patch
+ source = bl-exit-python2-path.patch
+ source = bl-hotcorners-syntax.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = af06407c74e40698d716acd5ddee6966
+ md5sums = 967a191ca673aec93546640002c794ab
+ md5sums = 2cb280313bd01a391437e4b960142d80
+
+pkgname = bunsen-utilities-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0c395842182
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: 2ion <dev@2ion.de>
+pkgname=bunsen-utilities-git
+pkgver=r72.22e76e4
+pkgrel=1
+pkgdesc="Collection of utility scripts"
+arch=('any')
+url="https://github.com/BunsenLabs/bunsen-utilities"
+license=('GPL3')
+depends=('python' 'pygtk' 'python-xlib' 'python-lxml')
+optdepends=(\
+ 'upower: Required for bl-exit' \
+ 'zenity: Required bl-conkyzen and bl-tint2edit')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(\
+ "${pkgname%-git}::git+https://github.com/BunsenLabs/bunsen-utilities.git#branch=master" \
+ 'https://raw.githubusercontent.com/Unia/bunsen-utilities/master/bl-aerosnap' \
+ 'https://raw.githubusercontent.com/Unia/bunsen-utilities/rewrite-hotcorners/bl-hotcorners' \
+ 'bl-kb-python2-path.patch' \
+ 'bl-exit-python2-path.patch' \
+ 'bl-hotcorners-syntax.patch')
+md5sums=(\
+ 'SKIP' \
+ 'SKIP' \
+ 'SKIP' \
+ 'af06407c74e40698d716acd5ddee6966' \
+ '967a191ca673aec93546640002c794ab' \
+ '2cb280313bd01a391437e4b960142d80')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch bl-kb ../bl-kb-python2-path.patch
+ patch bl-exit ../bl-exit-python2-path.patch
+ cd "$srcdir" ; cd ..
+ patch bl-hotcorners bl-hotcorners-syntax.patch
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "${pkgdir}/usr/bin"
+ install -t "${pkgdir}/usr/bin" bl-*
+ cd "$srcdir"
+ install -t "${pkgdir}/usr/bin" bl-aerosnap
+ install -t "${pkgdir}/usr/bin" bl-hotcorners
+}
diff --git a/bl-exit-python2-path.patch b/bl-exit-python2-path.patch
new file mode 100644
index 000000000000..276e48fe79b3
--- /dev/null
+++ b/bl-exit-python2-path.patch
@@ -0,0 +1,4 @@
+1c1
+< #!/usr/bin/env python
+---
+> #!/usr/bin/env python2
diff --git a/bl-hotcorners-syntax.patch b/bl-hotcorners-syntax.patch
new file mode 100644
index 000000000000..7a0d08e60f99
--- /dev/null
+++ b/bl-hotcorners-syntax.patch
@@ -0,0 +1,4 @@
+12c12
+< import sys, time, os, ConfigParser
+---
+> import sys, time, os, configparser
diff --git a/bl-kb-python2-path.patch b/bl-kb-python2-path.patch
new file mode 100644
index 000000000000..2c6429d5c70d
--- /dev/null
+++ b/bl-kb-python2-path.patch
@@ -0,0 +1,8 @@
+--- bl-kb 2015-09-02 12:19:29.403767220 +0200
++++ bl-kb-p 2015-09-02 12:39:19.630902915 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+
+ # This script reads the keybinds configuration file ("$HOME/.config/openbox/rc.xml")