summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2020-07-20 16:49:25 +0100
committerJoão Figueiredo2020-07-20 16:49:25 +0100
commit418a57228b89bfc9a27abf7c36351355a17c7966 (patch)
tree45aa1f8a8c5a63fea54a74fb60a7e350f27f2b61
parent90c711df1437c32ce77a5ea04d74adae54dcec93 (diff)
downloadaur-418a57228b89bfc9a27abf7c36351355a17c7966.tar.gz
Removed check(), no longer on devel branch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bd5e2dfbe86..a94352b8e331 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bup
pkgdesc = Efficient backup system based on the git packfile format
- pkgver = 0.30.r213.g093752b
- pkgrel = 6
+ pkgver = 0.30
+ pkgrel = 7
url = https://bup.github.io/
changelog = changelog.md
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = bup
depends = python2-pyxattr
depends = git
optdepends = python2-tornado: for bup web
- source = git+https://github.com/bup/bup.git
- sha512sums = SKIP
+ source = bup-0.30.tar.gz::https://github.com/bup/bup/archive/0.30.tar.gz
+ sha512sums = 8c500568ca2609e6b437b3a67c08976bbdb6fbad39c77eb7e74e503b5ffdc1cbe1e51b5e834e7db0481a3cfc38a55aeae49a8e53657994524b612e54136e7af1
pkgname = bup
diff --git a/PKGBUILD b/PKGBUILD
index a6d72a0fa0e6..1c5b31289370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# Contributor: SanskritFritz (gmail)
pkgname=bup
-pkgver=0.30.r213.g093752b
-pkgrel=6
+pkgver=0.30
+pkgrel=7
pkgdesc='Efficient backup system based on the git packfile format'
arch=('x86_64')
url='https://bup.github.io/'
@@ -19,29 +19,22 @@ depends=('python-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'git')
makedepends=('ruby-ronn' 'git' 'setconf' 'pandoc')
checkdepends=('rsync' 'python2-tornado')
optdepends=('python2-tornado: for bup web')
-#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz")
-source=("git+https://github.com/bup/bup.git")
-#sha512sums=('8c500568ca2609e6b437b3a67c08976bbdb6fbad39c77eb7e74e503b5ffdc1cbe1e51b5e834e7db0481a3cfc38a55aeae49a8e53657994524b612e54136e7af1')
-sha512sums=('SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz")
+sha512sums=('8c500568ca2609e6b437b3a67c08976bbdb6fbad39c77eb7e74e503b5ffdc1cbe1e51b5e834e7db0481a3cfc38a55aeae49a8e53657994524b612e54136e7af1')
changelog=changelog.md
-pkgver() {
- cd "$pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-check() {
- cd "$pkgname"
- LANG=C make test
-}
-
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
./configure
make
}
+#check() {
+# cd "$pkgname-$pkgver"
+# LANG=C make test
+#}
+
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" PREFIX=/usr install
}