summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2020-12-23 22:57:15 +0000
committerJoão Figueiredo2020-12-23 22:57:15 +0000
commit620d509e1c4223b15ca3d011fe740b40093b0bd8 (patch)
tree7145fbd05eaf00b91136c53b9312ac4fe094e1f3
parenta7e9f6dec364b75d77e96024df2ab10cc96d249e (diff)
downloadaur-620d509e1c4223b15ca3d011fe740b40093b0bd8.tar.gz
Backported python 3.9 support patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5931f1df952..419482353428 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = bup
pkgdesc = Efficient backup system based on the git packfile format
pkgver = 0.31
- pkgrel = 1
+ pkgrel = 2
url = https://bup.github.io/
changelog = changelog.md
arch = x86_64
license = GPL
- checkdepends = rsync
- checkdepends = python-tornado
makedepends = pandoc
depends = python-fuse
depends = par2cmdline
@@ -19,7 +17,9 @@ pkgbase = bup
optdepends = python-tornado: for bup web
conflicts = bup-git
source = bup-0.31.tar.gz::https://github.com/bup/bup/archive/0.31.tar.gz
+ source = argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch
sha256sums = 2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1
+ sha256sums = 09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315
pkgname = bup
diff --git a/PKGBUILD b/PKGBUILD
index 9cea18080529..10590676bd69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com> (11/07/2020)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com> (11/07/2020)
# Contributor: freggel.doe (Fixed i18n problem with make test, 13/07/2020)
# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
@@ -10,7 +10,7 @@
pkgname=bup
pkgver=0.31
-pkgrel=1
+pkgrel=2
pkgdesc='Efficient backup system based on the git packfile format'
arch=('x86_64')
url='https://bup.github.io/'
@@ -18,12 +18,20 @@ license=('GPL')
depends=('python-fuse' 'par2cmdline' 'python-pyxattr' 'acl' 'readline' 'attr' 'git')
optdepends=('python-tornado: for bup web')
makedepends=('pandoc')
-checkdepends=('rsync' 'python-tornado')
+#checkdepends=('rsync' 'python-tornado')
conflicts=('bup-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz")
-sha256sums=('2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz"
+ "argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch")
+sha256sums=('2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1'
+ '09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315')
changelog=changelog.md
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < ../argv.patch
+ #Backported patch for python 3.9 support: https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54
+}
+
build() {
cd "$pkgname-$pkgver"
./configure