summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2020-07-14 21:20:16 +0100
committerJoão Figueiredo2020-07-14 21:20:16 +0100
commit90c711df1437c32ce77a5ea04d74adae54dcec93 (patch)
treeb692a2593fa2d04d6c6261590f7f4024ee03383f
parenta4ab6b43a62b36083c657c0bdbf19a6767c961aa (diff)
downloadaur-90c711df1437c32ce77a5ea04d74adae54dcec93.tar.gz
Fixed make test (thanks @freggel.doe!) and deps
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6208f280cca6..5bd5e2dfbe86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bup
pkgdesc = Efficient backup system based on the git packfile format
- pkgver = 0.30
- pkgrel = 5
+ pkgver = 0.30.r213.g093752b
+ pkgrel = 6
url = https://bup.github.io/
changelog = changelog.md
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = bup
makedepends = git
makedepends = setconf
makedepends = pandoc
- depends = python2-fuse
+ depends = python-fuse
depends = par2cmdline
depends = pylibacl
depends = python2-pyxattr
diff --git a/PKGBUILD b/PKGBUILD
index e311981e7f08..a6d72a0fa0e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+# Maintainer: João Figueiredo <jf dot mundox at gmail dot com> (11/07/2020)
+# Contributor: freggel.doe (Fixed i18n problem with make test, 13/07/2020)
# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Jakob Matthes <jakob.matthes@gmail.com>
@@ -8,13 +9,13 @@
# Contributor: SanskritFritz (gmail)
pkgname=bup
-pkgver=0.30
-pkgrel=5
+pkgver=0.30.r213.g093752b
+pkgrel=6
pkgdesc='Efficient backup system based on the git packfile format'
arch=('x86_64')
url='https://bup.github.io/'
license=('GPL')
-depends=('python2-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'git')
+depends=('python-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'git')
makedepends=('ruby-ronn' 'git' 'setconf' 'pandoc')
checkdepends=('rsync' 'python2-tornado')
optdepends=('python2-tornado: for bup web')
@@ -24,18 +25,23 @@ source=("git+https://github.com/bup/bup.git")
sha512sums=('SKIP')
changelog=changelog.md
-build() {
- cd "${pkgname}"
- ./configure
- make
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
check() {
- cd "${pkgname}"
- make test
+ cd "$pkgname"
+ LANG=C make test
+}
+
+build() {
+ cd "$pkgname"
+ ./configure
+ make
}
package() {
- cd "${pkgname}"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}