summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2020-12-25 17:47:31 +0000
committerJoão Figueiredo2020-12-25 17:47:31 +0000
commita37396c8ea2b8c463f51e2182f5993f112938671 (patch)
tree13db409e2ead1618ab3cf80c01072c73cdb72290
parent620d509e1c4223b15ca3d011fe740b40093b0bd8 (diff)
downloadaur-a37396c8ea2b8c463f51e2182f5993f112938671.tar.gz
Added patch to prioritize python3 over other versions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--python.patch10
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 419482353428..5408a2a8eb1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bup
pkgdesc = Efficient backup system based on the git packfile format
pkgver = 0.31
- pkgrel = 2
+ pkgrel = 3
url = https://bup.github.io/
changelog = changelog.md
arch = x86_64
@@ -18,8 +18,10 @@ pkgbase = bup
conflicts = bup-git
source = bup-0.31.tar.gz::https://github.com/bup/bup/archive/0.31.tar.gz
source = argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch
+ source = python.patch
sha256sums = 2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1
sha256sums = 09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315
+ sha256sums = 24e2bc085f9b778cd8f553342436bf7174fd3983c0e34ce7ba84b2012dfa4062
pkgname = bup
diff --git a/PKGBUILD b/PKGBUILD
index 10590676bd69..fb54c5c6dd4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=bup
pkgver=0.31
-pkgrel=2
+pkgrel=3
pkgdesc='Efficient backup system based on the git packfile format'
arch=('x86_64')
url='https://bup.github.io/'
@@ -21,15 +21,21 @@ makedepends=('pandoc')
#checkdepends=('rsync' 'python-tornado')
conflicts=('bup-git')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz"
- "argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch")
+ "argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch"
+ "python.patch")
sha256sums=('2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1'
- '09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315')
+ '09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315'
+ '24e2bc085f9b778cd8f553342436bf7174fd3983c0e34ce7ba84b2012dfa4062')
changelog=changelog.md
prepare() {
cd "$pkgname-$pkgver"
patch -p1 < ../argv.patch
- #Backported patch for python 3.9 support: https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54
+ # Backport this commit for python 3.9 compiling support:
+ # https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54
+
+ patch -p1 < ../python.patch
+ # Always choose python3 over other versions
}
build() {
diff --git a/python.patch b/python.patch
new file mode 100644
index 000000000000..13dc292cfa3b
--- /dev/null
+++ b/python.patch
@@ -0,0 +1,10 @@
+--- a/config/configure 2020-08-22 18:12:01.000000000 +0100
++++ b/config/configure 2020-12-25 17:32:45.230892240 +0000
+@@ -66,6 +66,7 @@
+ AC_SUB bup_make "$MAKE"
+
+ bup_python="$(type -p "$PYTHON")"
++test -z "$bup_python" && bup_python="$(bup_find_prog python3 '')"
+ test -z "$bup_python" && bup_python="$(bup_find_prog python2.7 '')"
+ test -z "$bup_python" && bup_python="$(bup_find_prog python2.6 '')"
+ test -z "$bup_python" && bup_python="$(bup_find_prog python2 '')"