summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2020-07-10 20:54:29 +0200
committerChristian Rebischke2020-07-10 20:54:29 +0200
commite3c0c0bc3865f6f1b69ef5cfa82c73c7b7879105 (patch)
tree9839704197f0bceb356b0c14939c91fc09a8a2b5
downloadaur-e3c0c0bc3865f6f1b69ef5cfa82c73c7b7879105.tar.gz
import from community
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
-rw-r--r--changelog.md133
3 files changed, 196 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a02208cd4e3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = bup
+ pkgdesc = Efficient backup system based on the git packfile format
+ pkgver = 0.30
+ pkgrel = 2
+ url = https://bup.github.io/
+ changelog = changelog.md
+ arch = x86_64
+ license = GPL
+ checkdepends = rsync
+ checkdepends = python2-tornado
+ makedepends = ruby-ronn
+ makedepends = git
+ makedepends = setconf
+ makedepends = pandoc
+ depends = python2-fuse
+ depends = par2cmdline
+ depends = pylibacl
+ depends = python2-pyxattr
+ depends = git
+ optdepends = python2-tornado: for bup web
+ source = bup-0.30.tar.gz::https://github.com/bup/bup/archive/0.30.tar.gz
+ sha512sums = 8c500568ca2609e6b437b3a67c08976bbdb6fbad39c77eb7e74e503b5ffdc1cbe1e51b5e834e7db0481a3cfc38a55aeae49a8e53657994524b612e54136e7af1
+
+pkgname = bup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22fa40e1e1d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : Christian Rebischke <chris.rebischke@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Jakob Matthes <jakob.matthes@gmail.com>
+# Contributor: Bram Schoenmakers <me@bramschoenmakers.nl>
+# Contributor: henning mueller <henning@orgizm.net>
+# Contributor: rakoo (AUR)
+# Contributor: SanskritFritz (gmail)
+
+pkgname=bup
+pkgver=0.30
+pkgrel=2
+pkgdesc='Efficient backup system based on the git packfile format'
+arch=('x86_64')
+url='https://bup.github.io/'
+license=('GPL')
+depends=('python2-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'git')
+makedepends=('ruby-ronn' 'git' 'setconf' 'pandoc')
+checkdepends=('rsync' 'python2-tornado')
+optdepends=('python2-tornado: for bup web')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz")
+sha512sums=('8c500568ca2609e6b437b3a67c08976bbdb6fbad39c77eb7e74e503b5ffdc1cbe1e51b5e834e7db0481a3cfc38a55aeae49a8e53657994524b612e54136e7af1')
+changelog=changelog.md
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure
+ make
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}
diff --git a/changelog.md b/changelog.md
new file mode 100644
index 000000000000..160558c93f7b
--- /dev/null
+++ b/changelog.md
@@ -0,0 +1,133 @@
+
+Notable changes in 0.30 as compared to 0.29.3
+=============================================
+
+May require attention
+---------------------
+
+* The minimum `git` version required is now 1.5.6.
+
+* The `prune-older` command now keeps the most recent save in each
+ period group (day, week, month, ...) rather than the oldest.
+
+* `bup` now adds a zero-padded suffix to the names of saves with the
+ same timestamp (e.g. 1970-01-01-214640-07) in order to avoid
+ duplicates. The sequence number currently represents the save's
+ reversed position in default `git rev-list` order, so that given:
+
+ /foo/1970-01-01-214640-09
+ /foo/1970-01-01-214640-10
+
+ In the normal case, the -10 save would be the next save made after
+ -09 (and the -09 save would be the single parent commit for -10).
+
+* `bup` is not currently compatible with Python 3 and will now refuse
+ to run if the Python version is not 2 unless
+ `BUP_ALLOW_UNEXPECTED_PYTHON_VERSION=true` is set in the environment
+ (which can be useful for development and testing).
+
+* `bup ls -s` now reports the tree hash for commits unless
+ `--commit-hash` is also specified.
+
+General
+-------
+
+* `bup get` has been added. This command allows the transfer or
+ rewriting of data within and between repositories, local or remote.
+ Among other things, it can be used to append remote saves to a local
+ branch, which by extension supports merging repositories. See
+ `bup-get(1)` for further information, and please note, this is a new
+ *EXPERIMENTAL* command that can (intentionally) modify your data in
+ destructive ways. It is potentially much more dangerous than most
+ `bup` commands. Treat with caution.
+
+* `bup` can now restore directly from a remote repository via `bup
+ restore -r host:path ...`. See `bup-restore(1)` for more
+ information.
+
+* `bup ls` can now report information for remote repositories via `bup
+ ls -r host:path ...`. See `bup-ls(1)` for more information.
+
+* `bup` should respect the git pack.packSizeLimit setting when writing
+ packfiles, though at the moment it will only affect a remote
+ repository when the option is set there directly.
+
+* `bup save` now stores the size for all links and normal files. For
+ directories saved using this new format retrieving file sizes for
+ larger files should be notably less expensive. Among other things
+ this may improve the performance of commands like `bup ls -l` or
+ `find /some/fuse/dir -ls`.
+
+* The VFS (Virtual File System) that underlies many operations, and
+ provides the basis for commands like `restore`, `ls`, etc. has been
+ rewritten in a way that makes remote repository access easier,
+ should decrease the memory footprint in some cases (e.g. for bup
+ fuse), and should make it easier to provide more selective caching.
+ At the moment, data is just evicted at random once a threshold is
+ reached.
+
+* A `--noop <--blobs|--tree>` option has been added to `bup split`
+ which prints the resulting id without storing the data in the
+ repository.
+
+Bugs
+----
+
+* The way `bup` handles output from subprocesses (diagnostics,
+ progress, etc.) has been adjusted in a way that should make it less
+ likely that bup might continue running after the main process has
+ exited, say via a C-c (SIGINT).
+
+* `bup` should now respect the specified compression level when
+ writing to a remote repository.
+
+* `bup restore` now creates FIFOs with mkfifo, not mknod, which is
+ more portable. The previous approach did not work correctly on (at
+ least) some versions of NetBSD.
+
+* `bup` should no longer just crash when it encounters a commit with a
+ "mergetag" header. For the moment, it just ignores them, and
+ they'll be discarded whenever `bup` rewrites a commit, say via the
+ `rm`, `prune-older`, or `get` commands.
+
+* The bloom command should now end progress messages with \r, not \n,
+ which avoids leaving spurious output lines behind at exit.
+
+* A missing space has been added to the `bup split --bench` output.
+
+* Various Python version compatibility problems have been fixed,
+ including some of the incompatibilities introduced by Python 3.
+
+* Some issues with mincore on WSL have been fixed.
+
+* Some Android build incompatibilities have been fixed.
+
+
+Build system
+------------
+
+* The tests no longer assume pwd is in /bin.
+
+* The tests should be less sensitive to the locale.
+
+* `test-meta` should no longer try to apply chattr +T to files. 'T'
+ only works for directories, and newer Linux kernels actually reject
+ the attempt (as of at least 4.12, and maybe 4.10).
+
+* `test-rm` should no longer fail when newer versions of git
+ automatically create packed-refs.
+
+* `test-sparse-files` should be less likely to fail when run inside a
+ container.
+
+* `test-index-check-device` and `test-xdev` now use separate files for
+ their loopback mounts. Previously each was mounting the same image
+ twice, which could produce the same device number.
+
+Thanks to (at least)
+====================
+
+Alexander Barton, Artem Leshchev, Ben Kelly, Fabian 'xx4h' Melters,
+Greg Troxel, Jamie Wyrick, Julien Goodwin, Mateusz Konieczny,
+Nathaniel Filardo, Patrick Rouleau, Paul Kronenwetter, Rob Browning,
+Robert Evans, Tim Riemenschneider, and bedhanger