summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2015-05-23 13:31:12 +0200
committerGordian Edenhofer2015-05-23 13:31:12 +0200
commit23e1eda450bde5f694c84b031fd0346087f91d98 (patch)
treeebd173a016b815374e8fe0894bcc488878e018cd
downloadaur-23e1eda450bde5f694c84b031fd0346087f91d98.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD53
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcf935930e60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.1
+# Fri May 15 10:37:49 UTC 2015
+pkgbase = bup-git
+ pkgdesc = Highly efficient file backup system based on the git packfile format (development version)
+ pkgver = 1253.dd5a15f
+ pkgrel = 1
+ url = https://github.com/bup/bup
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ruby-ronn
+ depends = python2-fuse
+ depends = par2cmdline
+ depends = pylibacl
+ depends = python2-pyxattr
+ depends = git
+ optdepends = python2-tornado: launch a web server to examine backup sets
+ provides = bup
+ conflicts = bup
+ source = bup-git::git+https://github.com/bup/bup.git
+ md5sums = SKIP
+
+pkgname = bup-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..388a9f39f94b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+# Contributor: Michael Witten <mfwitten>
+# Contributor: Matthieu Rakotojaona <rakoo>
+
+pkgname=bup-git
+pkgver=1253.dd5a15f
+pkgrel=1
+pkgdesc='Highly efficient file backup system based on the git packfile format (development version)'
+arch=('i686' 'x86_64')
+url='https://github.com/bup/bup'
+license=('GPL')
+depends=('python2-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'git')
+optdepends=('python2-tornado: launch a web server to examine backup sets')
+makedepends=('ruby-ronn')
+provides=('bup')
+conflicts=('bup')
+source=("${pkgname}"::"git+https://github.com/bup/bup.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ # Fixing numerous false invocations since python2 is needed
+ find . -type f -exec sed -i -e '1s/env python\b/env python2/' {} +
+
+ sed -i -e 's/bup_find_prog python\b/bup_find_prog python2/' \
+ -e 's/MF_PATH_INCLUDE PYTHON python\b/MF_PATH_INCLUDE PYTHON python2/' \
+ config/configure
+
+ sed -i -e 's/PYTHON=python\b/PYTHON=python2/' -e '/docs-available/d' Makefile
+
+ sed -i -e 's/python\b -c/python2 -c/' t/{lib,test-meta,test-ls}.sh
+}
+
+build() {
+ make -C "${srcdir}/${pkgname}" all import-docs
+}
+
+# Checking routine fails because of unknown reason!
+# - disabled in favor of increased speed
+#check() {
+# make -C "${srcdir}/${pkgname}" test
+#}
+
+package() {
+ make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" install
+}