summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-05-08 16:22:05 +0200
committerGordian Edenhofer2016-05-08 16:22:05 +0200
commitfdf7b94a366437c0cb2ad28fa6b55cacb655cc10 (patch)
tree2c4bab099d22c74fa1e4dcb931efa3e7d3d85f8b
parenta46f6ba1756a18116d48da8833dad437e707b075 (diff)
downloadaur-fdf7b94a366437c0cb2ad28fa6b55cacb655cc10.tar.gz
upgpkg: bup-git 1364.cad3c11-2
Fix wrong documented PREFIX. Add manual pages. Minor dependency cleanup.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77f95f173b3d..1cc504d918d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = bup-git
- pkgdesc = Highly efficient file backup system based on the git packfile format (development version)
+ pkgdesc = Efficient file backup system based on the git packfile format
pkgver = 1364.cad3c11
- pkgrel = 1
- url = https://github.com/bup/bup
+ pkgrel = 2
+ url = https://bup.github.io/
arch = i686
arch = x86_64
license = GPL
- depends = python2
+ makedepends = pandoc
depends = python2-fuse
depends = par2cmdline
depends = pylibacl
depends = python2-pyxattr
- depends = attr
depends = acl
+ depends = attr
depends = git
optdepends = python2-tornado: launch a web server to examine backup sets
- provides = bup
+ provides = bup=1364.cad3c11
conflicts = bup
source = bup-git::git+https://github.com/bup/bup.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2fdf0fa9aa16..4c1dbb7d0aff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@
pkgname=bup-git
pkgver=1364.cad3c11
-pkgrel=1
-pkgdesc='Highly efficient file backup system based on the git packfile format (development version)'
+pkgrel=2
+pkgdesc='Efficient file backup system based on the git packfile format'
arch=('i686' 'x86_64')
-url='https://github.com/bup/bup'
+url='https://bup.github.io/'
license=('GPL')
-depends=('python2' 'python2-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'attr' 'acl' 'git')
+depends=('python2-fuse' 'par2cmdline' 'pylibacl' 'python2-pyxattr' 'acl' 'attr' 'git')
optdepends=('python2-tornado: launch a web server to examine backup sets')
-provides=('bup')
-conflicts=('bup')
+makedepends=('pandoc')
+#checkdepends=('rsync')
+provides=("bup=${pkgver}")
+conflicts=("bup")
source=("${pkgname}"::"git+https://github.com/bup/bup.git")
md5sums=('SKIP')
@@ -21,32 +23,30 @@ pkgver() {
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
-
prepare() {
cd "${srcdir}/${pkgname}"
# Fixing numerous false invocations since python2 is needed
find . -type f -exec sed -i -e '1s/env python\b/env python2/' {} +
-
- sed -i -e 's/bup_find_prog python\b/bup_find_prog python2/' \
- -e 's/MF_PATH_INCLUDE PYTHON python\b/MF_PATH_INCLUDE PYTHON python2/' \
- config/configure
-
+ sed -i -e 's/find_prog python\b/find_prog python2/' \
+ -e 's/MF_PATH_INCLUDE PYTHON python\b/MF_PATH_INCLUDE PYTHON python2/' \
+ config/configure
sed -i -e 's/PYTHON=python\b/PYTHON=python2/' -e '/docs-available/d' Makefile
-
sed -i -e 's/python\b -c/python2 -c/' t/{lib,test-meta,test-ls}.sh
+
+ # Make test suite happy
+ #git config --global user.email "bob@zombo.com"
}
build() {
- make -C "${srcdir}/${pkgname}" all import-docs
+ make -C "${srcdir}/${pkgname}"
}
-# Checking routine fails because of unknown reason!
-# - disabled in favor of increased speed
+# Disabled in favor of increased speed
#check() {
-# make -C "${srcdir}/${pkgname}" test
+# make -C "${srcdir}/${pkgname}" test -j1
#}
package() {
- make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" install
+ make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
}