summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Lybin2018-07-26 02:30:22 +0700
committerLev Lybin2018-07-26 02:30:22 +0700
commit4406364066c5ad5e1153c563397a770a3c3efca3 (patch)
tree3abd233adc0c35ed1f76176a39ba8e0c119eca68
parentdd737f89d6cf276c66d7e5dfaf48cf389b3d7f2f (diff)
downloadaur-4406364066c5ad5e1153c563397a770a3c3efca3.tar.gz
upgpkg: burstcoin-wallet 2.2.1-2
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
-rw-r--r--burstcoin-wallet.desktop7
-rw-r--r--burstcoin-wallet.install22
5 files changed, 53 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8e1b2940201..b01c65f0fdae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
pkgbase = burstcoin-wallet
pkgdesc = The world's first HDD-mined cryptocurrency using an energy efficient and fair Proof-of-Capacity (PoC) consensus algorithm.
pkgver = 2.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/PoC-Consortium/burstcoin
+ install = burstcoin-wallet.install
arch = i686
arch = x86_64
license = GPL3
depends = java-runtime-common
depends = java-runtime>=8
+ depends = xdg-utils
+ optdepends = mariadb: for storage
options = !strip
backup = opt/burstcoin-wallet/conf/logging-default.properties
backup = opt/burstcoin-wallet/conf/brs-default.properties
source = https://github.com/PoC-Consortium/burstcoin/releases/download/2.2.1/burstcoin-2.2.1.zip
source = burstcoin-wallet.service
+ source = burstcoin-wallet.desktop
sha256sums = 6bb82c125db2757bf7a92512907785c02a8312d910a85ca4e0600b3860a21bc1
sha256sums = 677aa600c97fcba5ec20f3e442f02acd920602e6bf08a8e536088fd6e2d15585
+ sha256sums = 44b494c86b4f8d7eeba365e83586e129543ceb67bc92a7b19df00918a8505865
pkgname = burstcoin-wallet
diff --git a/.gitignore b/.gitignore
index 92e4300d2955..86138d476df2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@
!.SRCINFO
!*.install
!.gitignore
+!burstcoin-wallet.desktop
!burstcoin-wallet.service
diff --git a/PKGBUILD b/PKGBUILD
index 475a760a6b1a..29f8e8e1f8da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,37 @@
# Contributor: Lev Lybin <lev.lybin@gmail.com>
pkgname=burstcoin-wallet
-_realname=burstcoin
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="The world's first HDD-mined cryptocurrency using an energy efficient and fair Proof-of-Capacity (PoC) consensus algorithm."
arch=('i686' 'x86_64')
url="https://github.com/PoC-Consortium/burstcoin"
license=('GPL3')
options=('!strip')
backup=(opt/burstcoin-wallet/conf/{logging-default.properties,brs-default.properties})
-depends=('java-runtime-common' 'java-runtime>=8')
+depends=('java-runtime-common' 'java-runtime>=8' 'xdg-utils')
+optdepends=('mariadb: for storage')
+install=burstcoin-wallet.install
source=(https://github.com/PoC-Consortium/burstcoin/releases/download/${pkgver}/burstcoin-${pkgver}.zip
burstcoin-wallet.service
+burstcoin-wallet.desktop
)
sha256sums=('6bb82c125db2757bf7a92512907785c02a8312d910a85ca4e0600b3860a21bc1'
- '677aa600c97fcba5ec20f3e442f02acd920602e6bf08a8e536088fd6e2d15585')
+ '677aa600c97fcba5ec20f3e442f02acd920602e6bf08a8e536088fd6e2d15585'
+ '44b494c86b4f8d7eeba365e83586e129543ceb67bc92a7b19df00918a8505865')
package() {
- install -dm755 $pkgdir/usr/lib/systemd/system
- install -dm755 $pkgdir/opt/$pkgname
-
- install -Dm644 burstcoin-wallet.service $pkgdir/usr/lib/systemd/system/burstcoin-wallet.service
-
cd $srcdir
- cp -dr --no-preserve=ownership {burst_db,conf,html,burst.jar,genscoop.cl,init-mysql.sql} $pkgdir/opt/$pkgname
+ # Lib directory
+ install -d $pkgdir/opt/$pkgname
+ cp -a burst_db conf html burst.jar genscoop.cl init-mysql.sql "$pkgdir/opt/$pkgname"
+ install -Dm755 burst.sh -t "$pkgdir/opt/$pkgname"
+
+ # Daemon
+ install -Dm644 "$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
- install -Dm755 burst.sh $pkgdir/opt/$pkgname
+ # Menu entry
+ install -Dm644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "html/ui/img/burst_logo_collapsed.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
}
diff --git a/burstcoin-wallet.desktop b/burstcoin-wallet.desktop
new file mode 100644
index 000000000000..2ffd1f1ae366
--- /dev/null
+++ b/burstcoin-wallet.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=BurstCoin Wallet
+Comment=Free, open-source, client-side tool for easily & securely interacting with the Burstcoin network
+Icon=burstcoin-wallet
+Exec=xdg-open "http://127.0.0.1:8125/index.html"
+Categories=Network;
diff --git a/burstcoin-wallet.install b/burstcoin-wallet.install
new file mode 100644
index 000000000000..d6d7606d8d0e
--- /dev/null
+++ b/burstcoin-wallet.install
@@ -0,0 +1,22 @@
+post_install() {
+ echo "+-------------------------------------------------------------------------------------+"
+ echo "| Config: /opt/burstcoin-wallet/conf/brs-default.properties |"
+ echo "| By default, burst wallet uses MySQL |"
+ echo "| |"
+ echo "| If you want to use MySQL: pacman -S mariadb |"
+ echo "| and configure by instruction: https://github.com/PoC-Consortium/burstcoin |"
+ echo "| |"
+ echo "| If you want to use H2 DB, you do not need to install additional, |"
+ echo "| change parameters in config, where DB.url is path to file where will storage DB: |"
+ echo "| DB.Url=jdbc:h2:/home/USER/burst_db/burst;DB_CLOSE_ON_EXIT=FALSE |"
+ echo "| DB.Username= |"
+ echo "| DB.Password= |"
+ echo "| |"
+ echo "| Run wallet: sudo systemctl start burstcoin-wallet.service |"
+ echo "| URL: http://127.0.0.1:8125/index.html |"
+ echo "+-------------------------------------------------------------------------------------+"
+}
+
+post_upgrade() {
+ post_install
+}