summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Lybin2018-03-17 20:59:41 +0700
committerLev Lybin2018-03-17 20:59:41 +0700
commitd87bf7c6574c6599c81265dfef7ddd95c98782f2 (patch)
tree93ea2631e031d94e05e62e0b5141e879e109cb7b
parenta778087cdf4d5be464d7fcd19dff36a130c1dd32 (diff)
downloadaur-d87bf7c6574c6599c81265dfef7ddd95c98782f2.tar.gz
upgpkg 2.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5872d77ce64b..700cc7c598ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
# Generated by mksrcinfo v8
-# Sat Jan 13 13:22:25 UTC 2018
+# Sat Mar 17 13:58:52 UTC 2018
pkgbase = burstcoin-wallet
pkgdesc = The world's first HDD-mined cryptocurrency using an energy efficient and fair Proof-of-Capacity (PoC) consensus algorithm.
- pkgver = 1.3.6cg
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/PoC-Consortium/burstcoin
arch = i686
arch = x86_64
- license = MIT
+ license = GPL3
depends = java-runtime-common
depends = java-runtime>=8
options = !strip
backup = opt/burstcoin-wallet/conf/logging-default.properties
backup = opt/burstcoin-wallet/conf/nxt-default.properties
- source = https://github.com/PoC-Consortium/burstcoin/releases/download/1.3.6cg/burstcoin-1.3.6cg.zip
+ backup = opt/burstcoin-wallet/conf/brs-default.properties
+ source = https://github.com/PoC-Consortium/burstcoin/releases/download/2.0.0/burstcoin-2.0.0.zip
source = burstcoin-wallet.service
- md5sums = b55ee43aa101abf7d13e4251e6ebb2ae
+ md5sums = 64ec7530d98e8594c9622c2ec44f3bc2
md5sums = ffc739247043a0b48b51278666fb095a
pkgname = burstcoin-wallet
diff --git a/PKGBUILD b/PKGBUILD
index 181259d738f7..dbcd49e584f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
pkgname=burstcoin-wallet
_realname=burstcoin
-pkgver=1.3.6cg
+pkgver=2.0.0
pkgrel=1
pkgdesc="The world's first HDD-mined cryptocurrency using an energy efficient and fair Proof-of-Capacity (PoC) consensus algorithm."
arch=('i686' 'x86_64')
url="https://github.com/PoC-Consortium/burstcoin"
-license=('MIT')
+license=('GPL3')
options=('!strip')
-backup=(opt/burstcoin-wallet/conf/{logging-default.properties,nxt-default.properties})
+backup=(opt/burstcoin-wallet/conf/{logging-default.properties,nxt-default.properties,brs-default.properties})
depends=('java-runtime-common' 'java-runtime>=8')
source=(https://github.com/PoC-Consortium/burstcoin/releases/download/${pkgver}/burstcoin-${pkgver}.zip
burstcoin-wallet.service
)
-md5sums=('b55ee43aa101abf7d13e4251e6ebb2ae'
+md5sums=('64ec7530d98e8594c9622c2ec44f3bc2'
'ffc739247043a0b48b51278666fb095a')
package() {
@@ -24,11 +24,11 @@ package() {
install -Dm644 burstcoin-wallet.service $pkgdir/usr/lib/systemd/system/burstcoin-wallet.service
- cd $srcdir/$_realname-$pkgver
+ cd $srcdir
- cp -dr --no-preserve=ownership {burst_db,conf,html,lib,burst.jar,Burst_Wallet.url,genscoop.cl,MIT-license.txt} $pkgdir/opt/$pkgname
+ cp -dr --no-preserve=ownership {burst_db,conf,html,burst.jar,Burst_Wallet.url,genscoop.cl} $pkgdir/opt/$pkgname
install -Dm755 burst.sh $pkgdir/opt/$pkgname
- sed -i -e 's/nxt.dbUrl.*/nxt.dbUrl=jdbc:h2:\/opt\/burstcoin-wallet\/burst_db\/burst;DB_CLOSE_ON_EXIT=FALSE/g' $pkgdir/opt/$pkgname/conf/nxt-default.properties
+ sed -i -e 's/DB.Url.*/DB.Url=jdbc:h2:\/opt\/burstcoin-wallet\/burst_db\/burst;DB_CLOSE_ON_EXIT=FALSE/g' $pkgdir/opt/$pkgname/conf/brs-default.properties
}