summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-03-24 15:55:30 +0000
committerGrey Christoforo2016-03-24 15:55:30 +0000
commit1de95333798ec0f372fb4f9598b3a5a73b38de4d (patch)
tree7e48cb925426525293499adef4e362705376cf1c
parent9336a3433e747cd15de9b392c4a2ecf3fc89fc4a (diff)
downloadaur-1de95333798ec0f372fb4f9598b3a5a73b38de4d.tar.gz
install python2 package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--bus-pirate.install7
3 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14948568fac3..a5dd473fb764 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 24 14:12:47 UTC 2016
+# Thu Mar 24 15:55:24 UTC 2016
pkgbase = bus-pirate
pkgdesc = Software and firmware for an open source hacker multi-tool that talks to electronic stuff
- pkgver = 2.3.5
+ pkgver = 2.3.7
pkgrel = 1
url = http://dangerousprototypes.com/docs/Bus_Pirate
install = bus-pirate.install
@@ -10,6 +10,7 @@ pkgbase = bus-pirate
license = CC-0
license = GPL
depends = qtchooser
+ depends = python2
options = !strip
options = docs
options = libtool
@@ -17,9 +18,9 @@ pkgbase = bus-pirate
options = !zipman
options = staticlibs
options = !upx
- source = https://github.com/greyltc/Bus_Pirate/archive/v2.3.5.tar.gz
+ source = https://github.com/greyltc/Bus_Pirate/archive/v2.3.7.tar.gz
source = 25_busBirate.rules
- md5sums = b7a70e3d88d4361cd89d081c89c6f790
+ md5sums = f16811dbb704c28c9b81366a53d3a419
md5sums = d939da558d713e498afc4343bc75ba47
pkgname = bus-pirate
diff --git a/PKGBUILD b/PKGBUILD
index c4a77e3f5c22..a2517021d59b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=bus-pirate
-pkgver=2.3.5
+pkgver=2.3.7
pkgrel=1
pkgdesc="Software and firmware for an open source hacker multi-tool that talks to electronic stuff"
url="http://dangerousprototypes.com/docs/Bus_Pirate"
arch=('any')
license=('CC-0' 'GPL')
-depends=('qtchooser')
+depends=('qtchooser' 'python2')
install=$pkgname.install
source=("https://github.com/greyltc/Bus_Pirate/archive/v${pkgver}.tar.gz" "25_busBirate.rules")
options=(!strip docs libtool emptydirs !zipman staticlibs !upx)
-md5sums=('b7a70e3d88d4361cd89d081c89c6f790'
+md5sums=('f16811dbb704c28c9b81366a53d3a419'
'd939da558d713e498afc4343bc75ba47')
prepare() {
@@ -21,22 +21,34 @@ prepare() {
}
build() {
+ msg2 "building QT5 GUI"
cd "${srcdir}/Bus_Pirate-${pkgver}/scripts/BusPirateGUI"
make
cp build/BusPirateGui .
make distclean
+
+ msg2 "building firmware flasher"
cd "${srcdir}/Bus_Pirate-${pkgver}/package/BPv4-firmware/pirate-loader-v4-source"
bash build-unix.sh
+
+ msg2 "building SPI sniffer"
+ cd "${srcdir}/Bus_Pirate-${pkgver}/scripts/powertools/SPISniffer/linux-version"
+ make
}
package() {
mkdir -p "${pkgdir}/opt/${pkgname}"
cp -a Bus_Pirate-${pkgver}/* "${pkgdir}/opt/${pkgname}/."
+ msg2 "packaging pyBusPirateLite"
+ cd "${srcdir}/Bus_Pirate-${pkgver}/scripts/pyBusPirateLite"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
# link exes
mkdir -p ${pkgdir}/usr/bin
ln -s /opt/${pkgname}/package/BPv4-firmware/pirate-loader-v4-source/pirate-loader_lnx ${pkgdir}/usr/bin/pirate-loader
ln -s /opt/${pkgname}/scripts/BusPirateGUI/BusPirateGui ${pkgdir}/usr/bin/bus-pirate-gui
+ ln -s /opt/${pkgname}/scripts/powertools/SPISniffer/linux-version/spisniffer ${pkgdir}/usr/bin/spi-sniffer
}
# vim:set ts=2 sw=2 et:
diff --git a/bus-pirate.install b/bus-pirate.install
index 8e013cc5a995..717615f4b411 100644
--- a/bus-pirate.install
+++ b/bus-pirate.install
@@ -3,8 +3,11 @@
usage () {
echo "Un- then re-plug the USB for your Bus Pirate, you should now find it at /dev/bus_pirate0"
- echo "bus-pirate-gui will launch a gui for your Bus Pirate."
- echo "pirate-loader is the command to use to flash new firmware"
+ echo ""
+ echo "Here are the tools provided by this package:"
+ echo "bus-pirate-gui: a gui for your Bus Pirate"
+ echo "pirate-loader: firmware flasher (see usage below)"
+ echo "spi-sniffer: listen to a SPI bus"
echo ""
echo "To flash a firmware file, you might:"
echo " 1. Short the PGC and PGD pins (right two) of the ICSP header"