summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenneth Endfinger2020-01-13 20:19:27 -0500
committerKenneth Endfinger2020-01-13 20:19:27 -0500
commitb4ed3e41205fa36f8f1efe75e85fc0199377ff20 (patch)
treec70e9fc2e2e20afa8b5b3ba8910c59a3ca7e0346
parent2573c69555d91ed4f861df21b036a87147b8ca05 (diff)
downloadaur-b4ed3e41205fa36f8f1efe75e85fc0199377ff20.tar.gz
Bring package up to standards.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD73
3 files changed, 46 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bbe228ad55f..96b9f1c1b9c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Dec 18 12:17:30 UTC 2016
pkgbase = bus1-git
pkgdesc = Bus1 Out-of-Tree Kernel Module
- pkgver = r937.dc398d5
- pkgrel = 1
+ pkgver = r977.20ee2f7
+ pkgrel = 2
url = http://www.bus1.org
- arch = x86_64
- arch = i686
+ arch = any
license = LGPL2.1
makedepends = git
makedepends = xmlto
makedepends = docbook-xsl
+ makedepends = dkms
source = git+https://github.com/bus1/bus1.git
source = dkms.conf
- sha256sums = SKIP
- sha256sums = 1dce1d7a39ca866c15fbeb305fbeebd1cafe40f02e4e42da77eaed5c6c2e9285
+ sha512sums = SKIP
+ sha512sums = cc123567141880104ffe153d18de342b58c79ae2b8833ee3df6fcd1b6dad76c58385a5f103362ff036d636c7ff5b5b2529a72b7c932c7d8bfba73b96e198e02c
pkgname = bus1-dkms-git
depends = dkms
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..832c13c613c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/src
+/pkg
+/bus1
+*.xz
+*.tar.*
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 4a22e87ac210..d27361a77053 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,68 @@
-# Maintainer: Timothée Ravier <tim@siosm.fr>
+# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
pkgbase=bus1-git
_pkgbase=${pkgbase/-git}
pkgname=(bus1-dkms-git bus1-headers-git bus1-doc-git)
-pkgver=r937.dc398d5
-pkgrel=1
+pkgver=r977.20ee2f7
+pkgrel=2
pkgdesc='Bus1 Out-of-Tree Kernel Module'
-arch=('x86_64' 'i686')
+arch=('any')
url='http://www.bus1.org'
-makedepends=('git' 'xmlto' 'docbook-xsl')
+makedepends=('git' 'xmlto' 'docbook-xsl' 'dkms')
license=('LGPL2.1')
source=("git+https://github.com/bus1/${_pkgbase}.git"
- 'dkms.conf')
-sha256sums=('SKIP'
- '1dce1d7a39ca866c15fbeb305fbeebd1cafe40f02e4e42da77eaed5c6c2e9285')
+ 'dkms.conf')
+sha512sums=('SKIP'
+ 'cc123567141880104ffe153d18de342b58c79ae2b8833ee3df6fcd1b6dad76c58385a5f103362ff036d636c7ff5b5b2529a72b7c932c7d8bfba73b96e198e02c')
pkgver() {
- cd ${_pkgbase}
+ cd ${_pkgbase}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd ${_pkgbase}
+ cd ${_pkgbase}
- make -f Makefile.docs
+ make -f Makefile.docs
}
package_bus1-dkms-git() {
- depends=('dkms')
- provides=('bus1' 'bus1-git')
- conflicts=('bus1' 'bus1-git')
+ depends=('dkms')
+ provides=('bus1' 'bus1-git')
+ conflicts=('bus1' 'bus1-git')
- cd ${_pkgbase}
+ cd ${_pkgbase}
- install -Dm0644 "${srcdir}"/dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+ install -Dm0644 "${srcdir}"/dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
- install -m0644 Makefile "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
+ install -m0644 Makefile "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
- install -dm0755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/ipc/bus1
- cp -a ipc/bus1 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/ipc/
+ install -dm0755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/ipc/bus1
+ cp -a ipc/bus1 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/ipc/
- install -Dm0644 include/uapi/linux/bus1.h \
- "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/include/uapi/linux/bus1.h
- install -dm0755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/usr/include/linux
- ln -s ../../../include/uapi/linux/bus1.h \
- "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/usr/include/linux
-
- # For testing only
- # install -dm0755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/tools/testing/selftests/bus1
- # install -m0644 tools/testing/selftests/bus1/* \
- # "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/tools/testing/selftests/bus1
+ install -Dm0644 include/uapi/linux/bus1.h \
+ "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/include/uapi/linux/bus1.h
+ install -dm0755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/usr/include/linux
+ ln -s ../../../include/uapi/linux/bus1.h \
+ "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/usr/include/linux
}
package_bus1-headers-git() {
- provides=('bus1-headers')
- conflicts=('bus1-headers')
+ provides=('bus1-headers')
+ conflicts=('bus1-headers')
- cd ${_pkgbase}
+ cd "${_pkgbase}"
- install -Dm 0644 include/uapi/linux/bus1.h "${pkgdir}"/usr/include/linux/bus1.h
+ install -Dm 0644 include/uapi/linux/bus1.h "${pkgdir}"/usr/include/linux/bus1.h
}
package_bus1-doc-git() {
- provides=('bus1-doc')
- conflicts=('bus1-doc')
+ provides=('bus1-doc')
+ conflicts=('bus1-doc')
- cd ${_pkgbase}
+ cd "${_pkgbase}"
- install -dm 0755 "${pkgdir}"/usr/share/man/man7/
- install -m 0644 Documentation/bus1/bus1*.7 "${pkgdir}"/usr/share/man/man7/
+ install -dm 0755 "${pkgdir}"/usr/share/man/man7/
+ install -m 0644 Documentation/bus1/bus1*.7 "${pkgdir}"/usr/share/man/man7/
}