summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2022-05-13 23:40:26 -0400
committerCody P Schafer2022-05-13 23:40:26 -0400
commita11f953ef0cdb9f59499f4395314870e3d63ccd6 (patch)
tree3ec009ec5b3ce2021e18b2a79fd0e91ae5733384
parentec265a8ac5f861d433c82161480f5e73e985185b (diff)
downloadaur-a11f953ef0cdb9f59499f4395314870e3d63ccd6.tar.gz
update to match non-git bustle PKGBUILD
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD73
3 files changed, 55 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c894e3e938e..590a1264bb72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,24 @@
-pkgbase = bustle-git
- pkgdesc = A dbus profiler
- pkgver = 0.6.2.r7.g7f663b6
+pkgbase = haskell-bustle
+ pkgdesc = Draw sequence diagrams of D-Bus traffic
+ pkgver = 0.8.0.r5.gf074e5a
pkgrel = 1
- url = https://www.freedesktop.org/wiki/Software/Bustle/
+ url = https://gitlab.freedesktop.org/bustle/bustle#readme
arch = x86_64
- license = GPLv3
- makedepends = git
- depends = ghc
- depends = happy
- depends = alex
- depends = gtk2hs-buildtools
+ license = custom: LGPL_2_1_or_later
+ makedepends = ghc
+ makedepends = haskell-hunit
+ makedepends = haskell-quickcheck
+ makedepends = haskell-test-framework
+ makedepends = haskell-test-framework-hunit
+ depends = ghc-libs
depends = haskell-cairo
- depends = haskell-dbus
+ depends = haskell-gio
depends = haskell-glib
depends = haskell-gtk
- depends = haskell-mtl
depends = haskell-pango
- depends = haskell-parsec
- depends = haskell-setlocale
- depends = haskell-pcap
- depends = haskell-hgettext
- depends = haskell-gio
- provides = bustle
- conflicts = bustle
- options = !emptydirs
- source = bustle-git::git+https://anongit.freedesktop.org/git/bustle.git
- md5sums = SKIP
-
-pkgname = bustle-git
+ depends = glib2
+ depends = libpcap
+ source = bustle::git+https://anongit.freedesktop.org/git/bustle.git
+ sha384sums = SKIP
+pkgname = haskell-bustle
diff --git a/.gitignore b/.gitignore
index ed38590ecaec..64427f5bca5a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
pkg/
src/
*.tar.*
-bustle-git/
+bustle/
diff --git a/PKGBUILD b/PKGBUILD
index dc897e36be7b..bd833be8ff89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,52 @@
-# Maintainer: Cody P Schafer <archlinux at codyps.com>
-_bpn=bustle
-pkgname=${_bpn}-git
-pkgver=0.6.2.r7.g7f663b6
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+# Maintainer: Your Name <youremail@domain.com>
+
+_hkgname=bustle
+pkgname=haskell-bustle
+pkgver=0.8.0.r5.gf074e5a
pkgrel=1
-pkgdesc="A dbus profiler"
-arch=(x86_64)
-url="https://www.freedesktop.org/wiki/Software/Bustle/"
-license=('GPLv3')
-groups=()
-depends=(ghc happy alex gtk2hs-buildtools haskell-cairo haskell-dbus haskell-glib haskell-gtk haskell-mtl haskell-pango haskell-parsec haskell-setlocale haskell-pcap haskell-hgettext haskell-gio)
-makedepends=(git)
-provides=(${_bpn})
-conflicts=(${_bpn})
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=($pkgname::git+https://anongit.freedesktop.org/git/bustle.git)
-md5sums=(SKIP)
+pkgdesc="Draw sequence diagrams of D-Bus traffic"
+url="https://gitlab.freedesktop.org/bustle/bustle#readme"
+license=("custom: LGPL_2_1_or_later")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-cairo' 'haskell-gio' 'haskell-glib' 'haskell-gtk' 'haskell-pango' 'glib2' 'libpcap')
+makedepends=('ghc' 'haskell-hunit' 'haskell-quickcheck' 'haskell-test-framework' 'haskell-test-framework-hunit')
+source=(
+ "$_hkgname::git+https://anongit.freedesktop.org/git/bustle.git"
+)
+
+sha384sums=(SKIP)
+_dir="$_hkgname"
pkgver() {
- cd "$pkgname"
+ cd "$_dir"
git describe --long | sed 's/^bustle-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "$pkgname"
+build() {
+ cd "$_dir"
+
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
- --datasubdir="$pkgname"
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
runhaskell Setup build
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
-_ghcver_set() {
- local _i
- _ghcver=`pacman -Q ghc | cut -f2 -d\ | cut -f1 -d-`
- depends[0]="ghc=$_ghcver"
+check() {
+ cd "$_dir"
+ runhaskell Setup test
}
package() {
- _ghcver_set
- cd "$pkgname"
+ cd "$_dir"
- runhaskell Setup copy --destdir=${pkgdir}
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 COPYING -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/COPYING
}
-
-# vim:set ts=2 sw=2 et: