summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Saric2022-11-18 01:56:54 +0100
committerIgor Saric2022-11-18 01:56:54 +0100
commitdfb966405145e931d45650fb91033181b97a5625 (patch)
tree3eb1e6909d9d2cf1ffcb59a88dcc01e0e213fcc3
downloadaur-busybox-crond.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84f18bacfffd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = busybox-crond
+ pkgdesc = Busybox crond implementation
+ pkgver = 1
+ pkgrel = 1
+ url = https://www.busybox.net
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = busybox
+ provides = cron
+ conflicts = cron
+ source = https://gitlab.alpinelinux.org/alpine/aports/-/raw/master/main/busybox/bbsuid.c
+ sha256sums = 99f6275a53a4005d8f03d87e5361699419b33a52b2b2e2fe1c45e90ab6d51f58
+
+pkgname = busybox-crond
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93b69575be37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Igor Saric <karabaja4 at gmail.com>
+# shellcheck disable=SC2148,SC2034,SC2154
+
+pkgname=busybox-crond
+pkgver=1
+pkgrel=1
+pkgdesc="Busybox crond implementation"
+arch=('x86_64')
+url="https://www.busybox.net"
+license=('GPL')
+depends=('busybox')
+makedepends=('gcc')
+conflicts=('cron')
+provides=('cron')
+source=("https://gitlab.alpinelinux.org/alpine/aports/-/raw/master/main/busybox/bbsuid.c")
+sha256sums=('99f6275a53a4005d8f03d87e5361699419b33a52b2b2e2fe1c45e90ab6d51f58')
+
+build() {
+ gcc "bbsuid.c" -o "bbsuid"
+}
+
+package() {
+ install -d "${pkgdir}/etc/crontabs"
+ install -d "${pkgdir}/var/spool/cron"
+ ln -sf "/etc/crontabs" "${pkgdir}/var/spool/cron/crontabs"
+
+ install -Dm4111 "bbsuid" "${pkgdir}/usr/bin/bbsuid"
+ ln -sf "/usr/bin/bbsuid" "${pkgdir}/usr/bin/crontab"
+
+ ln -sf "/usr/bin/busybox" "${pkgdir}/usr/bin/crond"
+}