summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordyn Carattini2016-08-24 17:53:10 -0500
committerJordyn Carattini2016-08-24 17:53:10 -0500
commitec16c9cf4fe96efd8ccc187df83400a880887a21 (patch)
tree2d198ccc5de60435de20c78797e176e831727b31
downloadaur-ec16c9cf4fe96efd8ccc187df83400a880887a21.tar.gz
created the package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--busybox-norootreboot.install16
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82e05891d0b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = busybox-norootreboot
+ pkgdesc = Utilities for rescue and embedded systems
+ pkgver = 1.25.0
+ pkgrel = 1
+ url = http://www.busybox.net
+ install = busybox-norootreboot.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ makedepends = gcc
+ makedepends = sed
+ makedepends = ncurses
+ provides = busybox
+ conflicts = busybox
+ conflicts = busybox-static
+ source = http://www.busybox.net/downloads/busybox-1.25.0.tar.bz2
+ source = https://raw.githubusercontent.com/jcjordyn130/aur-misc/master/busybox-norootreboot/halt.patch
+ md5sums = b05af9645076f75429a8683f8afcbdb3
+ md5sums = b5ab29025a588785ec7888d03e87823c
+
+pkgname = busybox-norootreboot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2bc356a5800
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jordyn Carattini (onlinecloud1@gmail.com)
+
+pkgname=busybox-norootreboot
+pkgver=1.25.0
+pkgrel=1
+pkgdesc="Utilities for rescue and embedded systems"
+arch=("i686" "x86_64")
+url="http://www.busybox.net"
+license=('GPL')
+provides=("busybox")
+conflicts=("busybox" "busybox-static")
+makedepends=("make" "gcc" "sed" "ncurses")
+install=busybox-norootreboot.install
+source=(
+ "$url/downloads/busybox-$pkgver.tar.bz2"
+ "https://raw.githubusercontent.com/jcjordyn130/aur-misc/master/busybox-norootreboot/halt.patch"
+)
+md5sums=('b05af9645076f75429a8683f8afcbdb3'
+ 'b5ab29025a588785ec7888d03e87823c')
+
+prepare() {
+ echo $pkgdir
+ cd "busybox-$pkgver"
+ patch -p1 -R < ../halt.patch
+ make clean
+ make defconfig
+}
+
+build() {
+ cd "busybox-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/busybox-$pkgver"
+ install -Dm755 busybox $pkgdir/usr/bin/busybox
+}
diff --git a/busybox-norootreboot.install b/busybox-norootreboot.install
new file mode 100644
index 000000000000..2d75985c038c
--- /dev/null
+++ b/busybox-norootreboot.install
@@ -0,0 +1,16 @@
+post_install() {
+ groupadd --system busybox
+ chmod -v +s /usr/bin/busybox
+ chown root:busybox -v /usr/bin/busybox
+ gpasswd --add root busybox
+ echo "You might want to add your user to the 'busybox' group"
+}
+
+post_remove() {
+ groupdel busybox
+}
+
+post_upgrade() {
+ chmod -v +s /usr/bin/busybox
+ chown root:busybox -v /usr/bin/busybox
+}