summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorelimpfor2017-02-22 06:02:18 -0500
committerelimpfor2017-02-22 06:02:18 -0500
commit34f41d7a94dd844e48233b2dd42aa64163c7b93b (patch)
treee774e967be843b0492337267a68a630f9c1b68ec
downloadaur-34f41d7a94dd844e48233b2dd42aa64163c7b93b.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdbc8f93040e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = busysteg-git
+ pkgdesc = Steganography tool to hide information content into busy areas of images, optimally
+ pkgver = r7.1ce6422
+ pkgrel = 1
+ url = https://github.com/jaybosamiya/busysteg
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = opencv
+ source = busysteg-git::git+git://github.com/jaybosamiya/busysteg.git
+ source = https://jay.mit-license.org/license.txt
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = busysteg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93f922531ec3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Elimpfor <aur@s403.33mail.com>
+pkgname=busysteg-git
+pkgver=r7.1ce6422
+pkgrel=1
+epoch=
+pkgdesc="Steganography tool to hide information content into busy areas of images, optimally"
+arch=('x86_64' 'i686')
+url="https://github.com/jaybosamiya/busysteg"
+license=('MIT')
+depends=('opencv')
+makedepends=('git' 'cmake')
+source=("${pkgname}::git+git://github.com/jaybosamiya/busysteg.git" "https://jay.mit-license.org/license.txt")
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ cmake .
+ make
+}
+
+package() {
+ install -D -m644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/${pkgname}"
+ install -D -m755 busysteg "$pkgdir/usr/bin/busysteg"
+}