summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-01-21 22:41:52 +0100
committerj.r2021-01-21 22:41:52 +0100
commita1ebe04354ec4c3d217b28325a88fcdbd54800f0 (patch)
treee46eca3e385019cf81c87dc71b0b9bf1e851c1f8
downloadaur-a1ebe04354ec4c3d217b28325a88fcdbd54800f0.tar.gz
Add buteo-git
This is basically a rename of eagle-xmpp-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06814b9e6e74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = buteo-git
+ pkgdesc = A XMPP based Groupware application
+ pkgver = r1.39dcd65
+ pkgrel = 1
+ url = https://buteo.codeberg.page/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = libstrophe
+ depends = glib2
+ depends = gpgme
+ depends = gtk3
+ depends = libvc
+ provides = buteo
+ conflicts = buteo
+ conflicts = eagle-xmpp-git
+ replaces = eagle-xmpp-git
+ source = buteo::git+https://codeberg.org/buteo/buteo.git
+ md5sums = SKIP
+
+pkgname = buteo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df8b70d91c3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: j.r <j.r@jugendhacker.de>
+_pkgname=buteo
+pkgname=$_pkgname-git
+pkgver=r1.39dcd65
+pkgrel=1
+pkgdesc="A XMPP based Groupware application"
+arch=('x86_64' 'i686')
+url="https://buteo.codeberg.page/"
+license=('GPL3')
+depends=('libstrophe' 'glib2' 'gpgme' 'gtk3' 'libvc')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname" 'eagle-xmpp-git')
+replaces=('eagle-xmpp-git')
+source=("$_pkgname::git+https://codeberg.org/buteo/buteo.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./bootstrap.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}