summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Butler2023-08-12 11:00:52 +0100
committerAlex Butler2023-08-12 11:00:52 +0100
commitfbda40e4e673ce773403ada7a7b095417d999127 (patch)
treee3128f59d813b8e8114a5eea11c9834050f72b6e
parentd6323c8b1c7cbc6ffed28e4b08fe245fa73ca9cb (diff)
downloadaur-fbda40e4e673ce773403ada7a7b095417d999127.tar.gz
15.21.0-2
name source zip file use exec in butler.sh
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--butler.sh2
3 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75279c841f44..d57a9174abde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = butler
pkgdesc = Command-line itch.io helper
pkgver = 15.21.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/itchio/butler
arch = x86_64
license = MIT
source = butler.sh
- source = https://broth.itch.ovh/butler/linux-amd64/15.21.0/archive/default
- sha256sums = 139d933a14939a6822cee27294aac9730d45d81dc7257d5dcd8a5f46913492a1
+ source = butler-15.21.0.zip::https://broth.itch.ovh/butler/linux-amd64/15.21.0/archive/default
+ sha256sums = 4db49b277678905279f323751b1d8704213549b45ed9332310b78f5421d8da7d
sha256sums = b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c
pkgname = butler
-
diff --git a/PKGBUILD b/PKGBUILD
index fd11bc0e29a2..7c9eac01f579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=butler
pkgver=15.21.0
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line itch.io helper'
arch=('x86_64')
url='https://github.com/itchio/butler'
license=('MIT')
source=("butler.sh"
- "https://broth.itch.ovh/butler/linux-amd64/$pkgver/archive/default")
-sha256sums=('139d933a14939a6822cee27294aac9730d45d81dc7257d5dcd8a5f46913492a1'
+ "$pkgname-$pkgver.zip::https://broth.itch.ovh/butler/linux-amd64/$pkgver/archive/default")
+sha256sums=('4db49b277678905279f323751b1d8704213549b45ed9332310b78f5421d8da7d'
'b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c')
package() {
diff --git a/butler.sh b/butler.sh
index 90cd8c7d4797..6cdea8ef558e 100644
--- a/butler.sh
+++ b/butler.sh
@@ -1,2 +1,2 @@
#!/usr/bin/env bash
-/usr/lib/butler/butler "$@"
+exec /usr/lib/butler/butler "$@"