summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2022-02-13 07:31:47 +0100
committernaetherm2022-02-13 07:31:47 +0100
commit7c6476a867c992cc588acee45498549ec49dd470 (patch)
tree0b1df7dff7118eabf78972f69b147b1160c7cc5c
parent1d26c78331bab93d8021911a4e79771627dbee52 (diff)
downloadaur-7c6476a867c992cc588acee45498549ec49dd470.tar.gz
Maybe fix for current building errors.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--arch_fix.patch14
3 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96612add1d35..83aa1d5e734b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = buttercup-desktop
pkgdesc = Javascript Password Vault - Multi-Platform Desktop Application
pkgver = 2.14.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/buttercup/buttercup-desktop
- arch = i686
arch = x86_64
license = GPL3
makedepends = npm
@@ -16,8 +15,10 @@ pkgbase = buttercup-desktop
source = buttercup-desktop-2.14.2.tar.gz::https://github.com/buttercup/buttercup-desktop/archive/v2.14.2.tar.gz
source = badge.svg
source = buttercup-desktop.desktop
+ source = arch_fix.patch
sha512sums = 2a4ea2bee95deb0aebd1a47443b30aae1c97de9f6a80a3076d67d4fd68b6ae2f5bd3ccf7b6cfdecd80c99a7b99c5aa1ac86af110cb32727aad986a43ae07f02b
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
pkgname = buttercup-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 7cc3f38afc6e..9507324481ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=buttercup-desktop
_pkgexename=buttercup
pkgver=2.14.2
-pkgrel=1
+pkgrel=2
pkgdesc='Javascript Password Vault - Multi-Platform Desktop Application'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/buttercup/buttercup-desktop"
license=('GPL3')
depends=('gtk3' 'libxss' 'nss' 'libsass')
@@ -15,10 +15,12 @@ makedepends=('npm' 'sed' 'nodejs')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/buttercup/buttercup-desktop/archive/v$pkgver.tar.gz"
badge.svg
- buttercup-desktop.desktop)
+ buttercup-desktop.desktop
+ arch_fix.patch)
sha512sums=(
'2a4ea2bee95deb0aebd1a47443b30aae1c97de9f6a80a3076d67d4fd68b6ae2f5bd3ccf7b6cfdecd80c99a7b99c5aa1ac86af110cb32727aad986a43ae07f02b'
SKIP
+ SKIP
SKIP)
prepare() {
sed -i '/"rpm",/d' "$srcdir/$pkgname-$pkgver/package.json"
@@ -28,11 +30,12 @@ prepare() {
if [[ $CARCH == "i686" ]]; then
sed -i 's/build --linux --x64/build --linux --ia32/' "$srcdir/$pkgname-$pkgver/package.json"
fi
-
+ patch --directory="$pkgname-$pkgver" --forward --strip=1 --input="${srcdir}/arch_fix.patch"
}
build() {
export NODE_ARCHITECTURE=x64
cd "$srcdir/$pkgname-$pkgver"
+ npm install keytar
npm install --cache "$srcdir/npm-cache"
npm run build
npm run package:linux
diff --git a/arch_fix.patch b/arch_fix.patch
new file mode 100644
index 000000000000..ea9f5d6c1768
--- /dev/null
+++ b/arch_fix.patch
@@ -0,0 +1,14 @@
+diff --unified --recursive --text a/package.json b/package.json
+--- a/package.json 2022-02-12 17:44:45.536886698 +0100
++++ b/package.json 2022-02-12 17:46:48.364179632 +0100
+@@ -78,9 +78,7 @@
+ {
+ "target": "appImage",
+ "arch": [
+- "x64",
+- "armv7l",
+- "arm64"
++ "x64"
+ ]
+ }
+ ],