summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-01 18:39:52 +0800
committerzxp198210052024-04-01 18:39:52 +0800
commit13ebf695238249fc0494250990076a56ddb12197 (patch)
treef1417315d67ad803dcda9ea465ef554f0d9b287a
parent972f67e7af2a5118ff6909c517b69703408fd850 (diff)
downloadaur-13ebf695238249fc0494250990076a56ddb12197.tar.gz
update to 2.27.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba23429958d3..ddcaaa29970d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buttercup-desktop-bin
pkgdesc = Cross-Platform Passwords & Secrets Vault
- pkgver = 2.26.5
+ pkgver = 2.27.0
pkgrel = 1
url = https://buttercup.pw/
arch = aarch64
@@ -9,15 +9,15 @@ pkgbase = buttercup-desktop-bin
license = GPL-3.0-only
makedepends = fuse2
depends = electron22
- provides = buttercup-desktop=2.26.5
+ provides = buttercup-desktop=2.27.0
conflicts = buttercup-desktop
source = buttercup-desktop.sh
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
- source_aarch64 = buttercup-desktop-2.26.5-aarch64.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.26.5/Buttercup-linux-arm64.AppImage
- sha256sums_aarch64 = 97fd17d80088e1028c6dd68ae1f5f22f84db757958329b4aaf9e4933f7f38061
- source_armv7h = buttercup-desktop-2.26.5-armv7h.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.26.5/Buttercup-linux-armv7l.AppImage
- sha256sums_armv7h = 1ca1d27576747fcb29c217d5f1d4153b2d3b5d571f7b2d1ab61f41fa1cc14d8e
- source_x86_64 = buttercup-desktop-2.26.5-x86_64.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.26.5/Buttercup-linux-x86_64.AppImage
- sha256sums_x86_64 = 78de2a913bed00a2374ebca0b3bac8850deb0970a272eb776ab09a3e0e3ddcb3
+ source_aarch64 = buttercup-desktop-2.27.0-aarch64.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.27.0/Buttercup-linux-arm64.AppImage
+ sha256sums_aarch64 = 316ec79a435ce15e1c5697907bea0d9b1a5cf3f923ffadb91f36ad7487cd603e
+ source_armv7h = buttercup-desktop-2.27.0-armv7h.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.27.0/Buttercup-linux-armv7l.AppImage
+ sha256sums_armv7h = c626ceae86323c62b57e5abb978cac406d1c572fd1cae33962bc37343d79a75a
+ source_x86_64 = buttercup-desktop-2.27.0-x86_64.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.27.0/Buttercup-linux-x86_64.AppImage
+ sha256sums_x86_64 = ce96f9737a867c1a115fd575955457f3ad3b84110782347c656262cdf60d8143
pkgname = buttercup-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 92eb69db3bfe..48971a61ebf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
_pkgname=buttercup
pkgname="${_pkgname}-desktop-bin"
-pkgver=2.26.5
+pkgver=2.27.0
_electronversion=22
pkgrel=1
pkgdesc="Cross-Platform Passwords & Secrets Vault"
@@ -26,9 +26,9 @@ source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_ghurl}/releases/do
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname//b/B}-linux-x86_64.AppImage")
source=("${pkgname%-bin}.sh")
sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('97fd17d80088e1028c6dd68ae1f5f22f84db757958329b4aaf9e4933f7f38061')
-sha256sums_armv7h=('1ca1d27576747fcb29c217d5f1d4153b2d3b5d571f7b2d1ab61f41fa1cc14d8e')
-sha256sums_x86_64=('78de2a913bed00a2374ebca0b3bac8850deb0970a272eb776ab09a3e0e3ddcb3')
+sha256sums_aarch64=('316ec79a435ce15e1c5697907bea0d9b1a5cf3f923ffadb91f36ad7487cd603e')
+sha256sums_armv7h=('c626ceae86323c62b57e5abb978cac406d1c572fd1cae33962bc37343d79a75a')
+sha256sums_x86_64=('ce96f9737a867c1a115fd575955457f3ad3b84110782347c656262cdf60d8143')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -40,6 +40,9 @@ build() {
sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g" \
-i "${srcdir}/squashfs-root/${_pkgname}.desktop"
}
+_electronversion() {
+ strings "${srcdir}/squashfs-root/${_pkgname}" | grep '^Chrome/[0-9.]* Electron/[0-9]' | awk '{print $2}' | tr -d "Electron/" | sed 's|\.| |g' | awk '{print $1}'
+}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"