summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-22 18:27:52 +0800
committerzxp198210052024-01-22 18:27:52 +0800
commit1c91d9badc09f7aa7cf874421de3a4d6ccc422d2 (patch)
tree78397886a55faa1bd308eebaed3cde8235b8389a
parentc66288c2134e2aa59e96ff7c734b90b18108abbb (diff)
downloadaur-1c91d9badc09f7aa7cf874421de3a4d6ccc422d2.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--buttercup-desktop.sh6
3 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4db13495a08b..a7d92c13532f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buttercup-desktop-bin
pkgdesc = Cross-Platform Passwords & Secrets Vault
pkgver = 2.24.4
- pkgrel = 1
+ pkgrel = 2
url = https://buttercup.pw/
arch = aarch64
arch = armv7h
@@ -10,16 +10,13 @@ pkgbase = buttercup-desktop-bin
makedepends = squashfuse
depends = electron22
depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = buttercup-desktop=2.24.4
conflicts = buttercup-desktop
source = buttercup-desktop.sh
- sha256sums = 68521cf799a902fb3c86aa1ebdcfa92566ee49621b0e1db5873a0501d893b2e6
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = buttercup-desktop-2.24.4-aarch64.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.24.4/Buttercup-linux-arm64.AppImage
sha256sums_aarch64 = ba9c950c3bd48da59d39a71bed5d020ae5ceb821968dc9e2d4f7da4a97140442
source_armv7h = buttercup-desktop-2.24.4-armv7h.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.24.4/Buttercup-linux-armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 5b8fe02c43fe..b4aeb78cf6ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname=buttercup
pkgname="${_pkgname}-desktop-bin"
pkgver=2.24.4
_electronversion=22
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-Platform Passwords & Secrets Vault"
arch=(
'aarch64'
@@ -18,12 +18,9 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -32,7 +29,7 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_ghurl}/releases/
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname//b/B}-linux-armv7l.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname//b/B}-linux-x86_64.AppImage")
source=("${pkgname%-bin}.sh")
-sha256sums=('68521cf799a902fb3c86aa1ebdcfa92566ee49621b0e1db5873a0501d893b2e6')
+sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('ba9c950c3bd48da59d39a71bed5d020ae5ceb821968dc9e2d4f7da4a97140442')
sha256sums_armv7h=('ad8f31dfd6353ce0d061d8dfd58af02b1cbd626dea93e96929d6bd376388bab0')
sha256sums_x86_64=('73930b8ffd4e4a31acc9208435e26a121b9bc65db2eee0e19ce040b4b1b2f762')
@@ -43,7 +40,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g" \
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g" \
-i "${srcdir}/squashfs-root/${_pkgname}.desktop"
}
package() {
diff --git a/buttercup-desktop.sh b/buttercup-desktop.sh
index 98f84b151b4f..aacd8f895847 100644
--- a/buttercup-desktop.sh
+++ b/buttercup-desktop.sh
@@ -6,10 +6,10 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file