summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-02 16:10:44 +0800
committerzxp198210052023-08-02 16:10:44 +0800
commit4932ccd46615cee3bfdae4aa309a0f6a8dd59350 (patch)
treefbeec325e506f74d7f292aca579f265465387500
parentc13200b6adaef202659788fa6c5c413a0c3929d1 (diff)
downloadaur-4932ccd46615cee3bfdae4aa309a0f6a8dd59350.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--buttercup-desktop.sh6
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93d1facdbde1..da5e19dd057a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = buttercup-desktop-bin
pkgdesc = Cross-Platform Passwords & Secrets Vault
pkgver = 2.20.3
- pkgrel = 1
+ pkgrel = 2
url = https://buttercup.pw/
arch = aarch64
arch = armv7h
arch = x86_64
license = GPL3
- depends = electron
+ depends = bash
+ depends = electron22
depends = hicolor-icon-theme
source = buttercup-desktop.sh
- sha256sums = a542d65f853688cde782a213642ef4c12d51734a28c314ea9ac993d7e9221344
+ sha256sums = 3c46bb45089efd35a1f503d32f3ca67ecf46b09b1636baeacdf0f3febe60135b
source_aarch64 = buttercup-desktop-2.20.3-aarch64.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.20.3/Buttercup-linux-arm64.AppImage
sha256sums_aarch64 = 76b885a9aae1a3f708f7202372b1c434a27d755275c24709d270f850dfca07e8
source_armv7h = buttercup-desktop-2.20.3-armv7h.AppImage::https://github.com/buttercup/buttercup-desktop/releases/download/v2.20.3/Buttercup-linux-armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 5fdce17cfba3..b4ae76d72746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=buttercup-desktop-bin
pkgver=2.20.3
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-Platform Passwords & Secrets Vault"
arch=('aarch64' 'armv7h' 'x86_64')
url="https://buttercup.pw/"
_githuburl="https://github.com/buttercup/buttercup-desktop"
license=('GPL3')
conflits=("${pkgname%-bin}")
-depends=('electron' 'hicolor-icon-theme')
+depends=('bash' 'electron22' 'hicolor-icon-theme')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_githuburl}/releases/download/v${pkgver}/Buttercup-linux-arm64.AppImage")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_githuburl}/releases/download/v${pkgver}/Buttercup-linux-armv7l.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_githuburl}/releases/download/v${pkgver}/Buttercup-linux-x86_64.AppImage")
source=("${pkgname%-bin}.sh")
-sha256sums=('a542d65f853688cde782a213642ef4c12d51734a28c314ea9ac993d7e9221344')
+sha256sums=('3c46bb45089efd35a1f503d32f3ca67ecf46b09b1636baeacdf0f3febe60135b')
sha256sums_aarch64=('76b885a9aae1a3f708f7202372b1c434a27d755275c24709d270f850dfca07e8')
sha256sums_armv7h=('ab49db4be607384a38b5365f9d796ccb4a3b8387dec37e9b096dfabeb1de8ef8')
sha256sums_x86_64=('7bb0998c94a400090d9fbdd9ddc83e0f9494751781a7aa6acfbccaadb907b37f')
diff --git a/buttercup-desktop.sh b/buttercup-desktop.sh
index 398a99db8acf..d9ecc9c9e8fc 100644
--- a/buttercup-desktop.sh
+++ b/buttercup-desktop.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron22
+_ASAR="/opt/buttercup-desktop/buttercup-desktop.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron /opt/buttercup-desktop/buttercup-desktop.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron --no-sandbox /opt/buttercup-desktop/buttercup-desktop.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file