summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuong Pham2015-08-15 08:04:25 -0700
committerDuong Pham2015-08-15 08:04:25 -0700
commitf1ff9ebc239ca7ad594f73607ac5e61db8ca3c53 (patch)
tree83d6995e955577f191dd46dd0e7f05a370b8646f
parent346a10de6adc9162ca7a4e963180fb4ff882b9bb (diff)
downloadaur-f1ff9ebc239ca7ad594f73607ac5e61db8ca3c53.tar.gz
upgpkg: 0.1.9
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD20
-rw-r--r--butterflow.install6
3 files changed, 20 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89aefda49cf5..92fa680d351f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,23 @@
pkgbase = butterflow
- pkgdesc = Make slow motion and smooth motion videos from the command line
- pkgver = 0.1.7
+ pkgdesc = Make slow motion and motion interpolated videos from the command line
+ pkgver = 0.1.9
pkgrel = 1
url = https://github.com/dthpham/butterflow
install = butterflow.install
arch = x86_64
license = custom
- makedepends = git
makedepends = python2-setuptools
depends = python2-numpy
- depends = ffmpeg>=2.4.1
- depends = opencv>=2.4.8
- depends = opencl-icd
- depends = x264
+ depends = ffmpeg
+ depends = opencv
+ depends = ocl-icd
+ optdepends = intel-opencl-runtime: Intel processor device support
optdepends = opencl-nvidia: NVIDIA device support
- optdepends = opencl-nvidia-304xx: NVIDIA legacy device support
- optdepends = opencl-nvidia-340xx: NVIDIA device support
optdepends = amdapp-sdk: AMD device suppport
- optdepends = opencl-mesa: AMD/ATI Radeon device support
- optdepends = intel-opencl-runtime: Intel processor device support
- optdepends = beignet-git: Intel IvyBridge device support
provides = butterflow
conflicts = butterflow
- source = http://srv.dthpham.me/butterflow-0.1.7.tar.gz
- sha256sums = f0f12fd90cddf7fa2079247f3f55b26bfaaca5d83e19a22697ed20b2169ec3a3
+ source = http://srv.dthpham.me/butterflow-0.1.9.tar.gz
+ sha256sums = 9f62960bb1a58c7fd7b67e7260d32a51e95ef5c7ff9f0811307463c1f1f338cf
pkgname = butterflow
diff --git a/PKGBUILD b/PKGBUILD
index c68c7cc1eb9d..07e3dcada8eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,21 @@
# Maintainer: Duong Pham <dthpham@gmail.com>
pkgname=butterflow
-pkgver=0.1.7
+pkgver=0.1.9
pkgrel=1
-pkgdesc="Make slow motion and smooth motion videos from the command line"
+pkgdesc="Make slow motion and motion interpolated videos from the command line"
arch=('x86_64')
url="https://github.com/dthpham/butterflow"
license=('custom')
-makedepends=('git' 'python2-setuptools')
-depends=('python2-numpy' 'ffmpeg>=2.4.1' 'opencv>=2.4.8' 'opencl-icd' 'x264')
-optdepends=('opencl-nvidia: NVIDIA device support'
- 'opencl-nvidia-304xx: NVIDIA legacy device support'
- 'opencl-nvidia-340xx: NVIDIA device support'
- 'amdapp-sdk: AMD device suppport'
- 'opencl-mesa: AMD/ATI Radeon device support'
- 'intel-opencl-runtime: Intel processor device support'
- 'beignet-git: Intel IvyBridge device support')
+makedepends=('python2-setuptools')
+depends=('python2-numpy' 'ffmpeg' 'opencv' 'ocl-icd')
+optdepends=('intel-opencl-runtime: Intel processor device support'
+ 'opencl-nvidia: NVIDIA device support'
+ 'amdapp-sdk: AMD device suppport')
provides=('butterflow')
conflicts=('butterflow')
install=butterflow.install
source=("http://srv.dthpham.me/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('f0f12fd90cddf7fa2079247f3f55b26bfaaca5d83e19a22697ed20b2169ec3a3')
+sha256sums=('9f62960bb1a58c7fd7b67e7260d32a51e95ef5c7ff9f0811307463c1f1f338cf')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/butterflow.install b/butterflow.install
index e301084c2091..c61983402f3f 100644
--- a/butterflow.install
+++ b/butterflow.install
@@ -1,6 +1,8 @@
post_install() {
echo "You still need to install at least one vendor-specific implementation of
- OpenCL that supports your hardware (see the suggested packages below). For
- information on how to satisfy this requirement, please read this Wiki page:
+ OpenCL that supports your hardware (see the suggested packages below). When
+ finished, you can run $ butterflow -d to print a list of all detected devices.
+ For more information on how to satisfy this requirement, please read this wiki
+ page:
https://wiki.archlinux.org/index.php/GPGPU"
}