summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEloy García2018-12-24 18:22:51 +0100
committerEloy García2018-12-24 18:22:51 +0100
commit154e13cb8448180f28604dbbb4d3cc8c1904d45e (patch)
tree15fba1402c7ed1f8744e04704b3c17802f561206
downloadaur-154e13cb8448180f28604dbbb4d3cc8c1904d45e.tar.gz
Version 1.0 of ButterManager
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae831de34616
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = buttermanager
+ pkgdesc = Graphical tool to create BTRFS snapshots, balance filesystems and upgrade the system safety
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/egara/buttermanager
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python>=3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python>=3
+ depends = btrfs-progs
+ source = git+https://github.com/egara/buttermanager.git#branch=master
+ md5sums = SKIP
+
+pkgname = buttermanager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b07414f3835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Eloy Garcia Almaden <eloy.garcia.pca@gmail.com>
+pkgname=buttermanager
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="Graphical tool to create BTRFS snapshots, balance filesystems and upgrade the system safety"
+arch=('x86_64')
+url="https://github.com/egara/buttermanager"
+license=('GPL')
+groups=()
+depends=('btrfs-progs' 'python>=3')
+makedepends=('git' 'python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('git+https://github.com/egara/buttermanager#branch=master')
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname"
+ # Dependencies and package installation
+ python setup.py install --user
+}
+
+package() {
+ cd "$pkgname"
+ # Creating destination directory
+ install -dm755 "$pkgdir/opt/$pkgname"
+
+ # Copying all the structure to the destination directory
+ cp -ar "$srcdir/$pkgname/$pkgname/" "$pkgdir/opt/$pkgname/"
+
+ # Copying .desktop file and icon
+ install -Dm644 "$srcdir/$pkgname/aur/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname/aur/$pkgname.svg" "$pkgdir/opt/$pkgname/gui/$pkgname.svg"
+}