summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEloy García Almadén2020-01-09 20:46:46 +0100
committerEloy García Almadén2020-01-09 20:46:46 +0100
commit823aa7e7bad4f09d5dea2ebc4950c9453c74394b (patch)
treea3cee06b7c5ad583033b738ff9a8a8c38b51b4b7
parent73ed599d9dbce845e84831071c7b7dd6333d3582 (diff)
downloadaur-823aa7e7bad4f09d5dea2ebc4950c9453c74394b.tar.gz
Upgrading version 1.7
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD45
2 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bed83a0d84b..175b5f7b331b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buttermanager
pkgdesc = Graphical tool to create BTRFS snapshots, balance filesystems and upgrade the system safetly
- pkgver = 1.6.1
+ pkgver = 1.7
pkgrel = 6
url = https://github.com/egara/buttermanager
arch = i686
@@ -8,12 +8,9 @@ pkgbase = buttermanager
license = GPL
makedepends = python>=3
makedepends = git
- makedepends = python-setuptools
depends = python>=3
depends = btrfs-progs
- depends = python-pyaml
source = git+https://github.com/egara/buttermanager.git#branch=master
md5sums = SKIP
pkgname = buttermanager
-
diff --git a/PKGBUILD b/PKGBUILD
index 3db12dffeff5..3d3c2de16047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Eloy Garcia Almaden <eloy.garcia.pca@gmail.com>
pkgname=buttermanager
-pkgver=1.6.1
+pkgver=1.7
pkgrel=6
epoch=
pkgdesc="Graphical tool to create BTRFS snapshots, balance filesystems and upgrade the system safetly"
@@ -8,8 +8,8 @@ arch=('x86_64')
url="https://github.com/egara/buttermanager"
license=('GPL')
groups=()
-depends=('btrfs-progs' 'python>=3' 'python-pyaml')
-makedepends=('git' 'python-setuptools')
+depends=('btrfs-progs' 'python>=3')
+makedepends=('python>=3' 'git')
checkdepends=()
optdepends=()
provides=()
@@ -24,21 +24,34 @@ noextract=()
md5sums=('SKIP')
validpgpkeys=()
-build() {
- cd "$pkgname"
- # Dependencies and package installation
- python setup.py install --user
-}
-
package() {
- cd "$pkgname"
+ cd "$pkgname"
# Creating destination directory
- install -dm755 "$pkgdir/opt/$pkgname"
+ install -dm755 "$pkgdir/opt/$pkgname"
+
+ # Copying all the structure to the destination directory
+ cp -ar "$srcdir/$pkgname/$pkgname/" "$pkgdir/opt/$pkgname/"
+
+ # Copying requirements
+ echo -e "\n Copying resources..."
+ cp -ar "requirements.txt" "$pkgdir/opt/$pkgname/"
+
+ # Creating virtual environment
+ echo -e "\n Creating virtual environment..."
+ cd "$pkgdir/opt/$pkgname/"
+ python -m venv env
+
+ # Enabling virtual environment
+ echo -e "\n Enabling virtual environment..."
+ source env/bin/activate
- # Copying all the structure to the destination directory
- cp -ar "$srcdir/$pkgname/$pkgname/" "$pkgdir/opt/$pkgname/"
+ # Installing requirements
+ echo -e "\n Installing all the required modules into the virtual environment. Please wait..."
+ pip install --upgrade pip
+ pip install -r requirements.txt
- # Copying .desktop file and icon
- install -Dm644 "$srcdir/$pkgname/aur/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$srcdir/$pkgname/aur/$pkgname.svg" "$pkgdir/opt/$pkgname/gui/$pkgname.svg"
+ # Copying .desktop file and icon
+ echo -e \n "Creating desktop icon. Finishing the installation"
+ install -Dm644 "$srcdir/$pkgname/aur/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname/aur/$pkgname.svg" "$pkgdir/opt/$pkgname/gui/$pkgname.svg"
}