summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuck-yeh2020-12-24 17:56:55 +0800
committerbuck-yeh2020-12-24 17:56:55 +0800
commit0a79a2aa447c2e2d6285cea9b73c2c6e77202030 (patch)
tree11c7e67e80f234ee8c3879994d49566a2c44eda3
parent0eb9cc2349f9d90b321dbf00e16ffae6d9d1ede6 (diff)
downloadaur-0a79a2aa447c2e2d6285cea9b73c2c6e77202030.tar.gz
Always include headers from bux/ subdir to save me days to implement CMake finding module.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d0a7284d2ad..e44ff26e8b75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bux
pkgdesc = A supplemental C++ library with functionalities not directly supported from Modern C++ standard.
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/buck-yeh/bux.git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9a445e4f5725..d34bc112cb77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,8 @@
# Maintainer: Buck Yeh <buck.yeh at gmail dot com>
pkgname=bux
-pkgver=1.0.0
+pkgver=1.1.0
+#pkgver=main
pkgrel=1
epoch=
pkgdesc='A supplemental C++ library with functionalities not directly supported from Modern C++ standard.'
@@ -24,7 +25,7 @@ backup=()
options=()
install=
changelog=
-source=() #"$pkgname-$pkgver.tar.gz")
+source=()
noextract=()
md5sums=()
validpgpkeys=()
@@ -33,7 +34,7 @@ prepare() {
rm -Rf "$pkgname"
mkdir -p "$pkgname"
cd "$pkgname" || return 1
- git clone -b main --single-branch $url .
+ git clone -b "$pkgver" --single-branch $url .
}
build() {
@@ -47,7 +48,7 @@ check() {
if [[ ! -f src/libbux.a ]]; then
return 1
fi
- for i in include/*.h ; do
+ for i in include/bux/*.h ; do
return 0
done
return 1
@@ -56,8 +57,8 @@ check() {
package() {
cd "$pkgname" || return 1
mkdir -p "$pkgdir/usr/lib"
- mkdir -p "$pkgdir/usr/include/$pkgname"
+ mkdir -p "$pkgdir/usr/include/bux"
cp src/libbux.a "$pkgdir/usr/lib/"
- cp include/*.h "$pkgdir/usr/include/$pkgname/"
+ cp include/bux/*.h "$pkgdir/usr/include/bux/"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}