summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuck-yeh2020-12-21 17:35:29 +0800
committerbuck-yeh2020-12-21 17:35:29 +0800
commit0eb9cc2349f9d90b321dbf00e16ffae6d9d1ede6 (patch)
treebd977ebd216f6c719b5c6875502ff61b2116bbf9
downloadaur-0eb9cc2349f9d90b321dbf00e16ffae6d9d1ede6.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD63
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d0a7284d2ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bux
+ pkgdesc = A supplemental C++ library with functionalities not directly supported from Modern C++ standard.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/buck-yeh/bux.git
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ makedepends = git
+ makedepends = binutils
+ makedepends = fakeroot
+ makedepends = gawk
+ depends = fmt
+
+pkgname = bux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a445e4f5725
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Buck Yeh <buck.yeh at gmail dot com>
+pkgname=bux
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc='A supplemental C++ library with functionalities not directly supported from Modern C++ standard.'
+arch=('x86_64')
+url='https://github.com/buck-yeh/bux.git'
+license=('MIT')
+groups=()
+depends=('fmt')
+makedepends=('cmake' 'make' 'gcc' 'git' 'binutils' 'fakeroot' 'gawk')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=() #"$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ rm -Rf "$pkgname"
+ mkdir -p "$pkgname"
+ cd "$pkgname" || return 1
+ git clone -b main --single-branch $url .
+}
+
+build() {
+ cd "$pkgname" || return 1
+ cmake .
+ make -j
+}
+
+check() {
+ cd "$pkgname" || return 1
+ if [[ ! -f src/libbux.a ]]; then
+ return 1
+ fi
+ for i in include/*.h ; do
+ return 0
+ done
+ return 1
+}
+
+package() {
+ cd "$pkgname" || return 1
+ mkdir -p "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/usr/include/$pkgname"
+ cp src/libbux.a "$pkgdir/usr/lib/"
+ cp include/*.h "$pkgdir/usr/include/$pkgname/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}