summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuck-yeh2021-02-17 16:26:51 +0800
committerbuck-yeh2021-02-17 16:26:51 +0800
commit31593bc7ac0755e2e735d80da3c47913d41cf883 (patch)
tree644362bb6222c9207ca517d55ebe07a9731ab4ca
parenta60f09c0666f85bd7bbbb09ddf20425db8a377dd (diff)
downloadaur-31593bc7ac0755e2e735d80da3c47913d41cf883.tar.gz
Conceptualize headers & add test cases
1. 🆕 `ParaUtil.h` with `bux::C_NumIter<>` 2. 🆕 `test/test_PO.cpp` for `PartialOrdering.h` 3. 🆕 `test/test_atomix.cpp` for `AtomiX.h` 4. ✍️ Conceptualize `Intervals.h` `PartialOrdering.h` `FA.h` and eliminate their dependencey to `<functional>` 4. ✍️ Refine function handler `bux::FH_ReadChar` in `UnicodeCvt.h` to return `std::optional<char>` insteal of **bool** 5. 🚮 Remove aged function classes `bux::FC_Parse*` from `StrUtil.h`
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f65f4208c8..0039a9711eb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bux
pkgdesc = A supplemental C++ library with functionalities not directly supported from Modern C++ standard.
- pkgver = 1.2.2
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/buck-yeh/bux.git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b1c731ccc898..ff459c994f43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Buck Yeh <buck.yeh at gmail dot com>
pkgname=bux
-pkgver=1.2.2
+pkgver=1.3.0
#pkgver=main
pkgrel=1
epoch=