summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwilga2016-11-01 18:48:55 +0100
committerwilga2016-11-01 18:48:55 +0100
commit907e745e4ad760efb194fe2ec762c8d1c2f9477f (patch)
tree0681863a14bb046233e1809a1764fde9cec39cd7
parentae40ba5bc06c2ca79e45896c4878f2354ccd82ba (diff)
downloadaur-907e745e4ad760efb194fe2ec762c8d1c2f9477f.tar.gz
new upstream version 10.6.447
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--bwsyncandshare-10.6.447.patch (renamed from bwsyncandshare-10.4.321.patch)6
3 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d0ee4f830a3..4a8944760f8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by makepkg 5.0.0
-# Fri Feb 26 10:43:31 UTC 2016
pkgbase = bwsyncandshare
pkgdesc = file sync and share client
- pkgver = 10.4.321
+ pkgver = 10.6.447
pkgrel = 1
url = https://bwsyncandshare.kit.edu
arch = any
license = custom
- depends = jre
+ depends = java-runtime
depends = gtk2
- noextract = bwSyncAndShare_v10.4.321_Linux.tar.gz
- source = http://download.bwsyncandshare.kit.edu/clients/bwSyncAndShare_v10.4.321_Linux.tar.gz
- source = bwsyncandshare-10.4.321.patch
- sha256sums = 1a36c94563110dcfc4dc76dc2c3702e2e62ac605b59e343e12aff4a76059d8af
- sha256sums = 3e0817014cf6b34e63a7ea02186190efdd392be08e5e07510a90622822c893cf
+ noextract = bwSyncAndShare_Latest_Linux.tar.gz
+ source = https://download.bwsyncandshare.kit.edu/clients/bwSyncAndShare_Latest_Linux.tar.gz
+ source = bwsyncandshare-10.6.447.patch
+ sha256sums = 9b3c876f494ceffd4a33b877200ae5c884e8ba72d56fe6a21ffa8733537092d0
+ sha256sums = 0d86a522fe6891f22ad07a2f470fed7b2a690d41dad62d085cb9f1b9135af98e
pkgname = bwsyncandshare
diff --git a/PKGBUILD b/PKGBUILD
index c506da79c02c..081f5ab96751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: wilga <wilga at cat3 dot de>
pkgname=bwsyncandshare
-pkgver=10.4.321
+pkgver=10.6.447
pkgrel=1
pkgdesc="file sync and share client"
arch=('any')
url="https://bwsyncandshare.kit.edu"
license=('custom')
-# the upstream package includes a bundled Oracle jre8 but we install it as a dependency instead
-depends=('jre' 'gtk2')
+# the upstream package includes a bundled Oracle jre8 but we remove it
+# and list java-runtime a dependency instead
+# NOTE: current version seems to require oracle jre and does NOT run with openjdk
+depends=('java-runtime' 'gtk2')
-# curl cannot use https since this server doesn't send intermediate CA certs so we must use http.
-# no security issue since the sha256sum we check against was computed from a https-downloaded copy
-_tarball="bwSyncAndShare_v${pkgver}_Linux.tar.gz"
-source=("http://download.bwsyncandshare.kit.edu/clients/$_tarball"
+# need to download "Latest" version since no version-numbered tarball exists
+# this will break when a new version is published
+_tarball="bwSyncAndShare_Latest_Linux.tar.gz"
+source=("https://download.bwsyncandshare.kit.edu/clients/$_tarball"
"$pkgname-$pkgver.patch")
noextract=("$_tarball")
-sha256sums=('1a36c94563110dcfc4dc76dc2c3702e2e62ac605b59e343e12aff4a76059d8af'
- '3e0817014cf6b34e63a7ea02186190efdd392be08e5e07510a90622822c893cf')
+
+sha256sums=('9b3c876f494ceffd4a33b877200ae5c884e8ba72d56fe6a21ffa8733537092d0'
+ '0d86a522fe6891f22ad07a2f470fed7b2a690d41dad62d085cb9f1b9135af98e')
prepare() {
tar xvzf $_tarball --exclude="bwSyncAndShare/jre" # remove bundled Oracle jre
diff --git a/bwsyncandshare-10.4.321.patch b/bwsyncandshare-10.6.447.patch
index 1bbe69debac2..88bd114f04b1 100644
--- a/bwsyncandshare-10.4.321.patch
+++ b/bwsyncandshare-10.6.447.patch
@@ -1,6 +1,6 @@
diff -aur bwSyncAndShare.pristine/bwSyncAndShare-Client.sh bwSyncAndShare/bwSyncAndShare-Client.sh
---- bwSyncAndShare.pristine/bwSyncAndShare-Client.sh 2015-12-01 16:30:53.000000000 +0100
-+++ bwSyncAndShare/bwSyncAndShare-Client.sh 2016-02-25 22:18:23.317595574 +0100
+--- bwSyncAndShare.pristine/bwSyncAndShare-Client.sh 2016-08-19 13:34:09.000000000 +0200
++++ bwSyncAndShare/bwSyncAndShare-Client.sh 2016-11-01 18:24:39.184803958 +0100
@@ -8,7 +8,7 @@
# CLIENT_INSTALL needs to point to the directory
# where the .jar file is located.
@@ -15,7 +15,7 @@ diff -aur bwSyncAndShare.pristine/bwSyncAndShare-Client.sh bwSyncAndShare/bwSync
# Set command line to invoke program start
#
-RUN_CMD="$CLIENT_INSTALL/jre/bin/java $JAVA_MEM -Duser.home=$CLIENT_HOME -cp $CP de.dal33t.Start"
-+RUN_CMD="/usr/lib/jvm/java-8-jre/jre/bin/java $JAVA_MEM -Duser.home=$CLIENT_HOME -cp $CP de.dal33t.Start"
++RUN_CMD="/usr/bin/java $JAVA_MEM -Duser.home=$CLIENT_HOME -cp $CP de.dal33t.Start"
#
# Silent mode