summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Rahimzadagan2024-01-27 16:58:26 +0100
committerNoah Rahimzadagan2024-01-27 16:58:26 +0100
commitc3fd997c5b6038017c87617fa21cd373c8921eba (patch)
tree3b31a006b379352ca7774a4e591b9cc131bed6a0
parentfaef591319d282e11b77053b7e842fc3a6fb82bb (diff)
downloadaur-c3fd997c5b6038017c87617fa21cd373c8921eba.tar.gz
Second commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 192683afc057..32780ad51568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,11 @@ pkgbase = byteblitz
url = https://github.com/noahra/byteblitz
arch = x86_64
license = GPL3
+ makedepends = cargo
makedepends = git
- source = https://github.com/noahra/byteblitz/releases/download/v1.0.0/byteblitz-x86_64-unknown-linux-gnu.tar.gz
- sha256sums = 824d39db6ade9f25a1f1d044b2bc85029369a1df5cf3084e3f31672577b7c1cf
+ source = https://github.com/noahra/byteblitz/archive/v1.0.0.tar.gz
+ sha256sums = SKIP
+ depends =
pkgname = byteblitz
diff --git a/PKGBUILD b/PKGBUILD
index f483de1e7826..f29f5eec1c5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,28 @@
+# Maintainer: Noah Rahimzadagan <noah.rahimzadagan@protonmail.com>
pkgname=byteblitz
-pkgver=1.0.0
+pkgver=1.0.0
pkgrel=1
-epoch=
pkgdesc="A CLI tool for viewing the binary content of files."
-arch=('x86_64')
-url="https://github.com/noahra/byteblitz"
-license=('GPL3')
-depends=()
-makedepends=('git')
-source=("https://github.com/noahra/byteblitz/releases/download/v1.0.0/byteblitz-x86_64-unknown-linux-gnu.tar.gz")
-sha256sums=('824d39db6ade9f25a1f1d044b2bc85029369a1df5cf3084e3f31672577b7c1cf')
+url='https://github.com/noahra/byteblitz'
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+arch=('x86_64')
+license=('GPL3')
+makedepends=('cargo' 'git')
+depends=()
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ cargo build --release --locked
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- install -Dm755 byteblitz "$pkgdir/usr/bin/byteblitz"
+ cd "$srcdir/$pkgname"
+ install -Dm755 target/release/byteblitz "$pkgdir/usr/bin/byteblitz"
}