summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniël van de Giessen2023-09-02 19:35:11 +0200
committerDaniël van de Giessen2023-09-02 19:35:11 +0200
commit00c3de80592dbc9978e6f963cfb9100bf65c8fbb (patch)
treecb294438b636c601c4f5e9e4a5860767a04bfb1c
downloadaur-00c3de80592dbc9978e6f963cfb9100bf65c8fbb.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eda547accc32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bytes-circle
+ pkgdesc = Show byte statistics as an ASCII circle graph
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://circulosmeos.wordpress.com/2015/10/10/statistics-circle-for-analysing-byte-entropy-in-files
+ arch = x86_64
+ license = GPL3
+ depends = glibc
+ source = bytes-circle-3.1-1.tar.gz::https://github.com/circulosmeos/circle/archive/refs/tags/v3.1-1-debian.tar.gz
+ sha256sums = 334036bcd86e95a780595ad9805504b485f0f35e619aa5b16edc22ab1f6fb63f
+
+pkgname = bytes-circle
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b5ec0570793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniël van de Giessen <aur@dvdgiessen.nl>
+pkgname=bytes-circle
+pkgver=3.1
+pkgrel=1
+pkgdesc='Show byte statistics as an ASCII circle graph'
+arch=('x86_64')
+url='https://circulosmeos.wordpress.com/2015/10/10/statistics-circle-for-analysing-byte-entropy-in-files'
+license=('GPL3')
+depends=('glibc')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/circulosmeos/circle/archive/refs/tags/v$pkgver-$pkgrel-debian.tar.gz")
+sha256sums=('334036bcd86e95a780595ad9805504b485f0f35e619aa5b16edc22ab1f6fb63f')
+
+build() {
+ cd "circle-$pkgver-$pkgrel-debian"
+ chmod +x configure
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "circle-$pkgver-$pkgrel-debian"
+ make -k check
+}
+
+package() {
+ cd "circle-$pkgver-$pkgrel-debian"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "debian/bytes-circle.1" "$pkgdir/usr/share/man/man1/bytes-circle.1"
+}