summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2019-06-11 10:54:52 -0600
committerMatt Coffin2019-06-11 10:54:52 -0600
commit3607ab58af5cca7e0b61dafdc6e482bf5c211e28 (patch)
tree0a5a10507833da051c3ac6b34657458d8f7e1ed1
parent631efd10830374f17dc94c4b0323c87df20de6fd (diff)
downloadaur-bzip2-git.tar.gz
Update license, URL, and convert to release build type
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 372bc22fa29a..b7f2e09e0c20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = bzip2-git
pkgdesc = A parallel, SMP-based, bzip2-compatible compression utility
pkgver = r66.ad723d6
- pkgrel = 2
- url = http://lbzip2.org/
+ pkgrel = 3
+ url = https://sourceware.org/bzip2/
arch = i686
arch = x86_64
- license = GPL3
+ license = custom
makedepends = perl
makedepends = git
makedepends = meson
diff --git a/PKGBUILD b/PKGBUILD
index b93955a30245..a37afbd2d212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,12 @@
-# Maintainer: Dan Ziemba <zman0900@gmail.com>
-# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
-# Contributor: Matt Coffin <mcoffin13 at gmail.com>
+# Maintainer: Matt Coffin <mcoffin13@gmail.com>
pkgname=bzip2-git
pkgver=r66.ad723d6
-pkgrel=2
+pkgrel=3
pkgdesc="A parallel, SMP-based, bzip2-compatible compression utility"
arch=('i686' 'x86_64')
-url="http://lbzip2.org/"
-license=('GPL3')
+url="https://sourceware.org/bzip2/"
+license=('custom')
depends=('glibc')
makedepends=('perl' 'git' 'meson' 'ninja')
provides=('bzip2')
@@ -26,7 +23,10 @@ pkgver() {
build() {
cd "$srcdir/$_gitname"
- meson builddir --prefix=/usr
+ meson \
+ --prefix=/usr \
+ --buildtype release \
+ builddir
ninja -C builddir
}
@@ -39,6 +39,8 @@ package() {
cd "$srcdir/$_gitname"
DESTDIR="$pkgdir" meson install -C builddir
+ install -D -m644 -t "$pkgdir/usr/share/licenses/$pkgname" ./COPYING
+
cd "$pkgdir/usr/lib"
if [ ! -e libbz2.so.1.0 ]; then
ln -s libbz2.so.1 libbz2.so.1.0