summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-02 23:39:31 +0200
committerMarcell Meszaros2022-07-02 23:47:49 +0200
commit24c47a8a1ffcb731f021f0e43979bb10ca4f064a (patch)
tree0b7f5f3d557750b9b74b819ac91e64c74d6ce742
parent6359157ac73b141cb5454dc5029f2e731a4dfb5b (diff)
downloadaur-24c47a8a1ffcb731f021f0e43979bb10ca4f064a.tar.gz
2.7.0-3 (2018-11-09 22:28:38 +0000)
This reverts commit 6359157ac73b141cb5454dc5029f2e731a4dfb5b.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD45
-rw-r--r--bzr-lazy-regex.patch20
-rw-r--r--bzr.sh5
5 files changed, 70 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16c3b0ed80bb..96f354c35ff1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,19 @@
pkgbase = bzr
- pkgdesc = DEPRECATED, replaced by breezy
- pkgver = 2.7.0.rip
- pkgrel = 666
+ pkgdesc = A decentralized revision control system (bazaar)
+ pkgver = 2.7.0
+ pkgrel = 3
url = https://bazaar.canonical.com/
- arch = any
+ arch = x86_64
license = GPL
- depends = sh
- source = bzr.sh
- b2sums = 1413a5ffe3c03d0c2eee5717b0f8846137e7d42ccf14a617b2e6fb437db1ce1afe2e7866484767dd078db52cb669779bc8aa85252d9dbea6d001c294cc9f2418
+ depends = python2
+ optdepends = python2-paramiko: SFTP support
+ source = https://launchpad.net/bzr/2.7/2.7.0/+download/bzr-2.7.0.tar.gz
+ source = https://launchpad.net/bzr/2.7/2.7.0/+download/bzr-2.7.0.tar.gz.sig
+ source = bzr-lazy-regex.patch
+ validpgpkeys = 84736900600FF95EF23513F52975A150DEF6218F
+ sha256sums = 0d451227b705a0dd21d8408353fe7e44d3a5069e6c4c26e5f146f1314b8fdab3
+ sha256sums = SKIP
+ sha256sums = b53c3dc8cba6f2c9758b61f0e9f40fc8452304e1fec15345e282dcd9d5657542
pkgname = bzr
+
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index cac58935c52e..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,17 +0,0 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
-*.orig
-*.bak
-*.backup
diff --git a/PKGBUILD b/PKGBUILD
index 3b19d4625b8c..dbaf061f4f49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,44 @@
-# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer : Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgname=bzr
-pkgver=2.7.0.rip
-pkgrel=666
-pkgdesc='DEPRECATED, replaced by breezy'
-arch=('any')
+pkgver=2.7.0
+pkgrel=3
+pkgdesc='A decentralized revision control system (bazaar)'
+arch=('x86_64')
url='https://bazaar.canonical.com/'
license=('GPL')
-depends=('sh')
-source=('bzr.sh')
-b2sums=('1413a5ffe3c03d0c2eee5717b0f8846137e7d42ccf14a617b2e6fb437db1ce1afe2e7866484767dd078db52cb669779bc8aa85252d9dbea6d001c294cc9f2418')
+depends=('python2')
+optdepends=('python2-paramiko: SFTP support')
+source=("https://launchpad.net/bzr/${pkgver%.*}/${pkgver}/+download/bzr-${pkgver}.tar.gz"{,.sig}
+ 'bzr-lazy-regex.patch')
+sha256sums=('0d451227b705a0dd21d8408353fe7e44d3a5069e6c4c26e5f146f1314b8fdab3'
+ 'SKIP'
+ 'b53c3dc8cba6f2c9758b61f0e9f40fc8452304e1fec15345e282dcd9d5657542')
+validpgpkeys=('84736900600FF95EF23513F52975A150DEF6218F') # Vincent Ladeuil
+
+prepare() {
+ cd bzr-${pkgver}
+
+ sed 's|man/man1|share/man/man1|' -i setup.py
+ sed 's|/usr/bin/env python|/usr/bin/env python2|' -i bzrlib/{plugins/bash_completion/bashcomp.py,tests/ssl_certs/create_ssls.py,patiencediff.py,_patiencediff_py.py}
+
+ patch -Np0 -i ../bzr-lazy-regex.patch
+}
+
+build() {
+ cd bzr-${pkgver}
+
+ python2 setup.py build
+}
package() {
- install -Dm 755 'bzr.sh' "${pkgdir}/usr/bin/bzr"
+ cd bzr-${pkgver}
+
+ python2 setup.py install --prefix='/usr' --root="${pkgdir}" --optimize='1'
+
+ install -dm 755 "${pkgdir}"/usr/share/bash-completion/completions
+ install -m 644 contrib/bash/bzr "${pkgdir}"/usr/share/bash-completion/completions/
}
+
+# vim: ts=2 sw=2 et:
diff --git a/bzr-lazy-regex.patch b/bzr-lazy-regex.patch
new file mode 100644
index 000000000000..8c547e7e4013
--- /dev/null
+++ b/bzr-lazy-regex.patch
@@ -0,0 +1,20 @@
+diff -u bzrlib/lazy_regex.py bzrlib/lazy_regex.py
+--- bzrlib/lazy_regex.py 2017-01-15 20:36:48 +0000
++++ bzrlib/lazy_regex.py 2017-01-30 09:08:25 +0000
+@@ -1,4 +1,4 @@
+-# Copyright (C) 2006 Canonical Ltd
++# Copyright (C) 2006, 2008-2011, 2017 Canonical Ltd
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -133,0 +134,10 @@
++
++
++# Some libraries calls re.finditer which fails it if receives a LazyRegex.
++if getattr(re, 'finditer', False):
++ def finditer_public(pattern, string, flags=0):
++ if isinstance(pattern, LazyRegex):
++ return pattern.finditer(string)
++ else:
++ return _real_re_compile(pattern, flags).finditer(string)
++ re.finditer = finditer_public
diff --git a/bzr.sh b/bzr.sh
deleted file mode 100644
index 5974dddc9dbd..000000000000
--- a/bzr.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/usr/bin/env sh
-
-echo 'bzr has been deprecated since 2017. Use breezy instead.'
-
-exit 127