summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Horky2015-07-02 11:16:01 +0200
committerVojtech Horky2015-07-02 11:16:01 +0200
commiteca7a19488bbde2b01a7a0b2072f966b9da6719c (patch)
tree311b1d44ffee3a0499f3209754812b5fd8f73ac3
downloadaur-eca7a19488bbde2b01a7a0b2072f966b9da6719c.tar.gz
bzr-bisect-bzr 84-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff0e0915d742
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bzr-bisect-bzr
+ pkgdesc = Bazaar plugin to find a bug using binary search
+ pkgver = 84
+ pkgrel = 1
+ url = https://launchpad.net/bzr-bisect/
+ arch = any
+ license = GPL
+ makedepends = bzr
+ makedepends = python2
+ depends = python2
+ depends = bzr
+
+pkgname = bzr-bisect-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f95c720b6db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Vojtech Horky <AUR / hotspur>
+pkgname=bzr-bisect-bzr
+pkgver=84
+pkgrel=1
+pkgdesc="Bazaar plugin to find a bug using binary search"
+arch=('any')
+url="https://launchpad.net/bzr-bisect/"
+license=('GPL')
+depends=("python2" "bzr")
+makedepends=("bzr" "python2")
+source=()
+md5sums=()
+_bzrbranch="lp:bzr-bisect"
+_bzrname="bzr-bisect"
+
+build() {
+ cd "${srcdir}"
+ msg "Connecting to BZR server..."
+
+ if [ -d "${srcdir}/${_bzrname}" ] ; then
+ cd "${_bzrname}" && bzr pull "${_bzrbranch}"
+ msg "Local repository updated."
+ else
+ bzr co "${_bzrbranch}"
+ msg "BZR checkout done or server timeout"
+ fi
+}
+
+package() {
+ cd "${srcdir}/${_bzrname}"
+ python2 ./setup.py install --prefix=/usr --root "${pkgdir}"
+}