summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Panter2013-01-07 00:11:58 +0000
committerJohannes Dewender2013-01-07 00:11:58 +0000
commitfd7b36132a7595a4968c0d3843d17a89c61bed9e (patch)
treeb8426dd35510957c6b8ab7fbf259d5639865c8a2
parent61c7d483f1c0b4605c805f1e279688433095265c (diff)
downloadaur-fd7b36132a7595a4968c0d3843d17a89c61bed9e.tar.gz
Split off package() part; remove “build_credits” call
This requires a “credits.pickle” file to be added to the source tree before it will work.
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cc3956d8903..5c389be16241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,8 +32,9 @@ build() {
sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
done
-
- cd "${startdir}/src/${pkgname}-${pkgver}/"
- python2 setup.py build_credits
- python2 setup.py install --prefix'=/usr' --root="${startdir}/pkg"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --prefix'=/usr' --root="${pkgdir}"
}