summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-11-14 20:16:25 -0500
committerGuillaume Horel2019-11-14 20:16:25 -0500
commit932a863eed2602675cc24f0d72404bb7520cf681 (patch)
treea1184dea38cb62d8263b94fda6088ff818100ccc
parent509d747f7e3694da338ac9f644ec3f3b96b62073 (diff)
downloadaur-932a863eed2602675cc24f0d72404bb7520cf681.tar.gz
update makedepends
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a58387216dc..622975e8ba9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = bzrtp-git
arch = x86_64
license = GPL2
makedepends = cmake
+ makedepends = git
depends = libxml2
depends = mbedtls
depends = bctoolbox-git
diff --git a/PKGBUILD b/PKGBUILD
index dbc55fb16ce0..2ddf210420d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ license=('GPL2')
conflicts=('bzrtp')
provides=('bzrtp')
depends=('libxml2' 'mbedtls' 'bctoolbox-git')
-makedepends=('cmake')
+makedepends=('cmake' 'git')
source=("git+https://github.com/BelledonneCommunications/bzrtp.git")
sha256sums=('SKIP')
@@ -20,6 +20,7 @@ pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
+
build() {
cd ${_pkgname}
cmake -DCMAKE_INSTALL_PREFIX=/usr \