summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-04-26 21:50:23 +0200
committerMartchus2016-04-26 21:50:23 +0200
commit0055831d8f911a2189da5beee07ac1ae35c53072 (patch)
treef6c9ccd2ad6d729c5a7c95f42d4179e30d00f0a3
parentda445ab1afc432a83d129eddba70ddc59445f4c4 (diff)
downloadaur-0055831d8f911a2189da5beee07ac1ae35c53072.tar.gz
updated version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 491c85872a0a..269b9adfe85f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Feb 27 01:49:21 UTC 2016
+# Tue Apr 26 19:50:22 UTC 2016
pkgbase = c++utilities
pkgdesc = Common C++ classes and routines used by my applications such as argument parser, IO and conversion utilities.
- pkgver = 3.2.0
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/Martchus/cpp-utilities
arch = i686
@@ -10,8 +10,8 @@ pkgbase = c++utilities
license = GPL
makedepends = cmake
depends = gcc-libs
- source = c++utilities-3.2.0.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v3.2.0.tar.gz
- sha256sums = b76a56237f5e318bb0e3d69fa9e685527807d77c6d89bcc9b59249a1d1a86d22
+ source = c++utilities-3.3.0.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v3.3.0.tar.gz
+ sha256sums = c1d0d9434f314f572a9137a0bb102d8f258ed969b776dd2576a16924b99b0e37
pkgname = c++utilities
diff --git a/PKGBUILD b/PKGBUILD
index e3b0bc55402e..72bbe1e739bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,11 @@
# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_reponame=cpp-utilities
pkgname=c++utilities
-pkgver=3.2.0
+pkgver=3.3.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Common C++ classes and routines used by my applications such as argument parser, IO and conversion utilities."
@@ -10,15 +14,15 @@ depends=('gcc-libs')
makedepends=('cmake')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('b76a56237f5e318bb0e3d69fa9e685527807d77c6d89bcc9b59249a1d1a86d22')
+sha256sums=('c1d0d9434f314f572a9137a0bb102d8f258ed969b776dd2576a16924b99b0e37')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr"
make
}
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- make install
+ make DESTDIR="${pkgdir}" install
}