summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-12-05 15:28:39 +0100
committerMartchus2023-12-05 15:28:39 +0100
commit124d65e7b70b60aedc6ec89c14c9195532f8c5dd (patch)
tree094092be5615bc39123338fcdd848415102dea6c
parente103b5661be92147ec2ae8579e3efb94dc3c5f39 (diff)
downloadaur-124d65e7b70b60aedc6ec89c14c9195532f8c5dd.tar.gz
Update version
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch60
-rw-r--r--0001-Fix-enabling-AppStream-tests.patch33
-rw-r--r--0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch35
-rw-r--r--PKGBUILD19
5 files changed, 8 insertions, 153 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf4c7a66d7f9..a1f390f1db86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = c++utilities
pkgdesc = Common C++ classes and routines such as argument parser, IO and conversion utilities
- pkgver = 5.24.2
- pkgrel = 3
+ pkgver = 5.24.3
+ pkgrel = 1
url = https://github.com/Martchus/cpp-utilities
arch = i686
arch = x86_64
@@ -15,13 +15,7 @@ pkgbase = c++utilities
depends = gcc-libs
optdepends = c++utilities-doc: API documentation
provides = libc++utilities.so
- source = c++utilities-5.24.2.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v5.24.2.tar.gz
- source = 0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
- source = 0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
- source = 0001-Fix-enabling-AppStream-tests.patch
- sha256sums = 46e79313900a8cbb7a3c0211fcc0cd07c2c8a6c2bcaeb11aec7fc706dc5914b1
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = c++utilities-5.24.3.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v5.24.3.tar.gz
+ sha256sums = a4a32f7fefad6754d400078a8078eb7a712bea7cf31f3bcb743dc962920d49b1
pkgname = c++utilities
diff --git a/0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch b/0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
deleted file mode 100644
index 7464a0b49cb1..000000000000
--- a/0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From a1bed55eda18b127750c7bff97f97474cd5c3ce9 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Wed, 22 Nov 2023 12:56:30 +0100
-Subject: [PATCH 1/2] Enable tidy tests only by default via
- `ENABLE_DEVEL_DEFAULTS`
-
-This test is only relevant for development. Additionally, the behavior of
-clang-format differs slightly between versions so this can really cause
-needlessly failures.
----
- cmake/modules/BasicConfig.cmake | 24 ++++++++++++++++--------
- 1 file changed, 16 insertions(+), 8 deletions(-)
-
-diff --git a/cmake/modules/BasicConfig.cmake b/cmake/modules/BasicConfig.cmake
-index 6a9d65a..dc9a696 100644
---- a/cmake/modules/BasicConfig.cmake
-+++ b/cmake/modules/BasicConfig.cmake
-@@ -403,8 +403,14 @@ if (NOT META_NO_TIDY)
- if (CMAKE_FORMAT_BIN)
- set(CMAKE_FORMAT_ENABLED_DEFAULT ON)
- endif ()
-+ set(TIDY_TESTS_ENABLED_DEFAULT OFF)
-+ if (ENABLE_DEVEL_DEFAULTS AND CLANG_FORMAT_ENABLED_DEFAULT)
-+ set(TIDY_TESTS_ENABLED_DEFAULT ON)
-+ endif ()
- option(CLANG_FORMAT_ENABLED "enables creation of tidy target using clang-format" "${CLANG_FORMAT_ENABLED_DEFAULT}")
- option(CMAKE_FORMAT_ENABLED "enables creation of tidy target using cmake-format" "${CMAKE_FORMAT_ENABLED_DEFAULT}")
-+ option(TIDY_TESTS_ENABLED "enables tests for checking whether code is well-formatted using clang-format"
-+ "${TIDY_TESTS_ENABLED_DEFAULT}")
- endif ()
-
- # add target for tidying with clang-format
-@@ -427,14 +433,16 @@ if (NOT META_NO_TIDY
- add_dependencies(tidy "${META_TARGET_NAME}_tidy")
-
- # also add a test to verify whether sources are tidy
-- add_test(
-- NAME "${META_TARGET_NAME}_tidy_test"
-- COMMAND "${CLANG_FORMAT_BIN}" -output-replacements-xml -style=file ${FORMATABLE_FILES}
-- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")
-- list(APPEND CHECK_TARGET_DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/.clang-format")
-- set_tests_properties(
-- "${META_TARGET_NAME}_tidy_test" PROPERTIES FAIL_REGULAR_EXPRESSION "<replacement.*>.*</replacement>" REQUIRED_FILES
-- "${CMAKE_CURRENT_SOURCE_DIR}/.clang-format")
-+ if (TIDY_TESTS_ENABLED)
-+ add_test(
-+ NAME "${META_TARGET_NAME}_tidy_test"
-+ COMMAND "${CLANG_FORMAT_BIN}" -output-replacements-xml -style=file ${FORMATABLE_FILES}
-+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")
-+ list(APPEND CHECK_TARGET_DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/.clang-format")
-+ set_tests_properties(
-+ "${META_TARGET_NAME}_tidy_test" PROPERTIES FAIL_REGULAR_EXPRESSION "<replacement.*>.*</replacement>"
-+ REQUIRED_FILES "${CMAKE_CURRENT_SOURCE_DIR}/.clang-format")
-+ endif ()
- endif ()
-
- # add target for tidying with cmake-format
---
-2.42.1
-
diff --git a/0001-Fix-enabling-AppStream-tests.patch b/0001-Fix-enabling-AppStream-tests.patch
deleted file mode 100644
index 76ee40cef9ef..000000000000
--- a/0001-Fix-enabling-AppStream-tests.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 35f56d486c7f6c4b110a27476e9114f3e19c0fae Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Thu, 30 Nov 2023 19:44:08 +0100
-Subject: [PATCH] Fix enabling AppStream tests
-
----
- cmake/modules/AppUtilities.cmake | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/cmake/modules/AppUtilities.cmake b/cmake/modules/AppUtilities.cmake
-index 2272431..bd93d92 100644
---- a/cmake/modules/AppUtilities.cmake
-+++ b/cmake/modules/AppUtilities.cmake
-@@ -86,10 +86,12 @@ function (add_appstream_file)
- set(APPSTREAM_TESTS_ENABLED_DEFAULT ON)
- endif ()
- option(APPSTREAM_TESTS_ENABLED "enables tests for checking whether AppStream files" "${APPSTREAM_TESTS_ENABLED_DEFAULT}")
-- if (NOT APPSTREAMCLI_BIN)
-- message(FATAL_ERROR "Unable to validate appstreamcli files; appstreamcli not found")
-- else ()
-- add_test(NAME "${META_TARGET_NAME}_appstream_validation" COMMAND "${APPSTREAMCLI_BIN}" validate "${APPSTREAM_FILE}")
-+ if (APPSTREAM_TESTS_ENABLED)
-+ if (NOT APPSTREAMCLI_BIN)
-+ message(FATAL_ERROR "Unable to validate appstreamcli files; appstreamcli not found")
-+ else ()
-+ add_test(NAME "${META_TARGET_NAME}_appstream_validation" COMMAND "${APPSTREAMCLI_BIN}" validate "${APPSTREAM_FILE}")
-+ endif ()
- endif ()
- endfunction ()
-
---
-2.43.0
-
diff --git a/0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch b/0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
deleted file mode 100644
index be676b3d7a43..000000000000
--- a/0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 8fb7de6fe0ce506d1521f586ab841266b2783ef8 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Wed, 22 Nov 2023 12:59:20 +0100
-Subject: [PATCH 2/2] Enable AppStream tests only by default via
- `ENABLE_DEVEL_DEFAULTS`
-
-This test already fails on deprecations so it is likely not a good idea to
-run it in general as it would cause needless failures.
----
- cmake/modules/AppUtilities.cmake | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/cmake/modules/AppUtilities.cmake b/cmake/modules/AppUtilities.cmake
-index 9a46b48..2272431 100644
---- a/cmake/modules/AppUtilities.cmake
-+++ b/cmake/modules/AppUtilities.cmake
-@@ -80,9 +80,14 @@ function (add_appstream_file)
- COMPONENT appimage)
-
- # add test
-+ set(APPSTREAM_TESTS_ENABLED_DEFAULT OFF)
- find_program(APPSTREAMCLI_BIN "appstreamcli")
-+ if (ENABLE_DEVEL_DEFAULTS AND APPSTREAMCLI_BIN)
-+ set(APPSTREAM_TESTS_ENABLED_DEFAULT ON)
-+ endif ()
-+ option(APPSTREAM_TESTS_ENABLED "enables tests for checking whether AppStream files" "${APPSTREAM_TESTS_ENABLED_DEFAULT}")
- if (NOT APPSTREAMCLI_BIN)
-- message(STATUS "Could not find appstreamcli; won't add test/target to validate appstream files")
-+ message(FATAL_ERROR "Unable to validate appstreamcli files; appstreamcli not found")
- else ()
- add_test(NAME "${META_TARGET_NAME}_appstream_validation" COMMAND "${APPSTREAMCLI_BIN}" validate "${APPSTREAM_FILE}")
- endif ()
---
-2.42.1
-
diff --git a/PKGBUILD b/PKGBUILD
index a17888216510..4299a7c08bf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_reponame=cpp-utilities
pkgname=c++utilities
-pkgver=5.24.2
-pkgrel=3
+pkgver=5.24.3
+pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Common C++ classes and routines such as argument parser, IO and conversion utilities'
license=('GPL')
@@ -16,19 +16,8 @@ makedepends=('cmake' 'ninja')
checkdepends=('cppunit')
provides=(libc++utilities.so)
url="https://github.com/Martchus/${_reponame}"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
- 0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
- 0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
- 0001-Fix-enabling-AppStream-tests.patch)
-sha256sums=('46e79313900a8cbb7a3c0211fcc0cd07c2c8a6c2bcaeb11aec7fc706dc5914b1'
- SKIP SKIP SKIP)
-
-prepare() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- patch -p1 -i ../0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
- patch -p1 -i ../0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
- patch -p1 -i ../0001-Fix-enabling-AppStream-tests.patch
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('a4a32f7fefad6754d400078a8078eb7a712bea7cf31f3bcb743dc962920d49b1')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"