summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2015-12-27 23:04:13 +0100
committerMartchus2015-12-27 23:04:13 +0100
commit60b177af1f34329735d22bc43a6e39eb1330a9a3 (patch)
treef1cf06c1d40966a269044e8ae72ef997cb4726ea
parent283f70227de9168ffd68ac64ce0f5587ad26ce0f (diff)
downloadaur-60b177af1f34329735d22bc43a6e39eb1330a9a3.tar.gz
updated version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 100d7c51a10c..7edf51fbc599 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 22:04:13 UTC 2015
pkgbase = c++utilities
pkgdesc = Common C++ classes and routines used by my applications such as argument parser, IO and conversion utilities.
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/Martchus/cpp-utilities
arch = i686
arch = x86_64
license = GPL
- makedepends = qt5-base
+ makedepends = cmake
depends = gcc-libs
- source = c++utilities-3.0.0.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v3.0.0.tar.gz
- sha256sums = 6de9cb9d9d2af191be79652590d5a23dfaa886c5384c59e7227508542d764dff
+ source = c++utilities-3.1.0.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v3.1.0.tar.gz
+ sha256sums = 6a97975bd5614493cec700b9d5733a4dd78cbc361e05848b302f79ac6142915d
pkgname = c++utilities
diff --git a/PKGBUILD b/PKGBUILD
index cdb26a048a7d..800b94fa27bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Maintainer: Martchus <martchus@gmx.net>
+_reponame=cpp-utilities
pkgname=c++utilities
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
arch=('i686' 'x86_64')
-pkgdesc="Common C++ classes and routines used by my applications such
-as argument parser, IO and conversion utilities."
+pkgdesc="Common C++ classes and routines used by my applications such as argument parser, IO and conversion utilities."
license=('GPL')
depends=('gcc-libs')
-makedepends=('qt5-base')
-url="https://github.com/Martchus/cpp-utilities"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v${pkgver}.tar.gz")
-_reponame=cpp-utilities
-sha256sums=('6de9cb9d9d2af191be79652590d5a23dfaa886c5384c59e7227508542d764dff')
+makedepends=('cmake')
+url="https://github.com/Martchus/${_reponame}"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('6a97975bd5614493cec700b9d5733a4dd78cbc361e05848b302f79ac6142915d')
build() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- INSTALL_ROOT=$pkgdir/usr/ qmake-qt5 "$pkgname.pro"
- make
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ make
}
package() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- make install
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make install
}