summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2019-08-24 23:15:10 +0200
committerMartchus2019-08-24 23:15:10 +0200
commita9c299b0df8fb2280084d23045e8364345558bb9 (patch)
treeb77b09c790a972a344df90bbf767bd07385af98f
parent3e4053ae6a9658fad651806d87ca5732b67f9d12 (diff)
downloadaur-a9c299b0df8fb2280084d23045e8364345558bb9.tar.gz
Update version
-rw-r--r--.SRCINFO6
-rw-r--r--.sync-conflict-20190519-131723-PKPUQWZ.SRCINFO19
-rw-r--r--PKGBUILD10
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 375191597057..bbd4575d0fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = c++utilities
pkgdesc = Common C++ classes and routines such as argument parser, IO and conversion utilities
- pkgver = 4.17.1
+ pkgver = 5.0.0
pkgrel = 1
url = https://github.com/Martchus/cpp-utilities
arch = i686
@@ -12,8 +12,8 @@ pkgbase = c++utilities
checkdepends = cppunit
makedepends = cmake
optdepends = c++utilities-doc: API documentation
- source = c++utilities-4.17.1.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v4.17.1.tar.gz
- sha256sums = c5cbca152eb43e3b2e16309d934fc5832a5c52d83dfca2d231d26384d8fe3805
+ source = c++utilities-5.0.0.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v5.0.0.tar.gz
+ sha256sums = 92d288b606b4f32d69686cbf5a264f90e5e00d80894583a9df2284d593cdc2b4
pkgname = c++utilities
diff --git a/.sync-conflict-20190519-131723-PKPUQWZ.SRCINFO b/.sync-conflict-20190519-131723-PKPUQWZ.SRCINFO
new file mode 100644
index 000000000000..85cf5205fa04
--- /dev/null
+++ b/.sync-conflict-20190519-131723-PKPUQWZ.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = c++utilities
+ pkgdesc = Common C++ classes and routines such as argument parser, IO and conversion utilities
+ pkgver = 4.17.0
+ pkgrel = 1
+ url = https://github.com/Martchus/cpp-utilities
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ checkdepends = cppunit
+ makedepends = cmake
+ optdepends = c++utilities-doc: API documentation
+ source = c++utilities-4.17.0.tar.gz::https://github.com/Martchus/cpp-utilities/archive/v4.17.0.tar.gz
+ sha256sums = 92d288b606b4f32d69686cbf5a264f90e5e00d80894583a9df2284d593cdc2b4
+
+pkgname = c++utilities
+
diff --git a/PKGBUILD b/PKGBUILD
index 1dfa49e90f8a..82a0b4e20973 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_reponame=cpp-utilities
pkgname=c++utilities
-pkgver=4.17.1
+pkgver=5.0.0
pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Common C++ classes and routines such as argument parser, IO and conversion utilities'
@@ -16,7 +16,7 @@ makedepends=('cmake')
checkdepends=('cppunit')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('c5cbca152eb43e3b2e16309d934fc5832a5c52d83dfca2d231d26384d8fe3805')
+sha256sums=('92d288b606b4f32d69686cbf5a264f90e5e00d80894583a9df2284d593cdc2b4')
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
@@ -24,7 +24,11 @@ prepare() {
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" .
+ cmake \
+ -DCMAKE_BUILD_TYPE:STRING='Release' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ .
make
}